I am in a stick situation with dual-booting Windows 8 and Ubuntu, and I want to wipe my computer to factory settings.

I have a Lenovo Ideapad Y510P with Windows 8 and Ubuntu 12.04 Dual-Booted. I also had to install rEFInd in order to get things "working."

I first discovered a problem when I went to start Lenovo One-Key Recovery (Version 8) in Windows, and selected the "System Recovery" option. I received the error:

"The program cannot find the service partition. The selected service is unavailable."

After a little googling, I came across the source of my problem: resizing partitions. A while ago (probably late July or early August), I needed to in order to attempt the dual-boot with Windows 8 and Ubuntu, and this "breaks" the one key recovery process by messing with the partition labels and whatnot.

My next step was looking around to solve that issue. I stumbled across this article: http://amigotechnotes.wordpress.com/2013/12/07/recover-lenovo-one-key-rescue-after-resizing-partitions/

After reading what was going on, I compared my partitions to what they should approximately be on this link (I don't know exactly what they are, if anyone has an untouched Y510P that can help with that, it would be greatly appreciated).

Here is what they were before:


Note that I only know for sure that partitions 9 and 10 are associated with Ubuntu, and partitions 1-7 are associated with Windows. I am pretty sure partitions 8 is also associated with windows. I change P1 from OEM to Recovery, P6 from Primary to Recovery, P7 from OEM to Primary, and P8 from Unknown to Recovery.

I followed all of the directions from the above link I posted and I rebooted. I still could not use the One Key Recovery.

So, I am here with a few questions, as I have been stuck on this for a while now:

  1. Do I have to delete/format my Linux Partitions and resize my Windows partitions to include them in order to use One Key again?

  2. If so, how can I determine what system (Windows or Ubuntu) Partition 8 belongs to?

  3. If not, are there any ways to fix this problem?

Any help would be greatly appreciated :)

UPDATE: I used the Windows 8 Reset My PC option to get everything back to factory settings, so I don't have this issue anymore. Thanks for the help, though! :)

  • 1
    Please don't edit your question to mark it as solved. Add your solution as an answer, then accept it.
    – user201262
    Jan 9, 2014 at 15:50

3 Answers 3


I recommend you do one of two things:

  • Contact Lenovo to obtain an OEM recovery disc (or USB flash drive) for your computer.
  • Obtain a retail Windows disc, as discussed here.

You should then be able to restore your system -- either to factory defaults (using the OEM disc) or to a standard "retail" installation. Either approach means that you won't have to guess about the status of any of your partitions. You could easily dig yourself into deeper trouble by making such guesses.


In short

  1. Follow Recover Lenovo One Key Rescue after Resizing Partitions to fix your partition ID.
  2. Follow Reset your Lenovo Computer with Windows 8 to reset your computer to factory default with Windows RE. If you want to keep your partition, please choose to keep your existing partition during reset your computer.


You may need to change the partition type by a dispart (a Windows utility) in command prompt running as an administrator to match the original setting. The original partition ID can be found in [info.ini] in [OKRBackup/Factory] folder in PBR_DRV partition.

Then try to launch Lenovo One Key Rescue to [System Recover] mode and restore factory default.

Or use Windows RE which can be created in [Recovery] in Windows 8 Control Panel and choose to [Reset My Computer]

If you want to keep your partition, please choose to keep your existing partition during reset your computer.

More Thoughts

If you have dual boot with Windows 8 and Linux, Boot Process in Windows and Linux with BIOS or UEFI might help. There might be issue related to fail to find the bootloader of Lenovo OneKey Rescue by your boot program in GUID Partition Table (GPT).

BTW, I found ClonZilla will change the OEM partition type to primary while cloning, too. Detail is in Recover Lenovo One Key Rescue Restore Feature after Cloning with CloneZilla It will stops you from recovering from backup sets. But you may launch and backup with the Lenovo One Key Rescue, just cannot restore.

P.S. Check the hyperlinks for more detail information. It's too much to put every detail instruction here.

Final Words

These are all due to the new partition types and programs who fail to identify them.

Edward Gudz and I both follow my blog and save the expanse for getting a factory recovery disk. Therefore, I have two facts to proof this works. Therefore, I might need to see your info.ini or I don't know what is your factory default partitions.


I finally found the simplest way to do the partitioning without loosing OKR in 2 steps:

Things I did before even thinking about using OKR from a shutdown state and/or doing shrink/partitioning stuff:
1. I had created a system recovery from within windows by using the OKR key

  1. shrink default volume "C" to its new size (using windows disk management tool)
  2. use pwhe (search for "pwhe disk partition") to create a new partition out of newly recovered unallocated space.

How I verified OKR:

  1. after doing all the partitioning yada yada >> shutdown >> pushed the novo key >> got the menu >> selected recovery >> (and there it was :smileyhappy: ) the OKR recovery menu

  2. I have not tried restoring my OS from recovery lol but I guess if the OKR is showing up just fine then it should work fine as well.

Can anyone out there confirm this?

Lenovo forum's link where I have put this up: http://forums.lenovo.com/t5/IdeaPad-Y-U-V-Z-and-P-series/Disk-Partitioning-Stock-Y510P-Setup-Easy-Way/td-p/1651136

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.