I am on Debian Jessie/Sid 64-bit and trying to use:

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Seymour [Radeon HD 6400M/7400M Series]

I installed the ATI drivers based on https://wiki.debian.org/ATIProprietary#configure. I am getting "Oh no! Something has gone wrong " instead of proper GDM. I removed the .Xauthority file, the temp X files, etc., but none of that was any help.

Then I installed the amd-catalyst-13.11-beta6-linux-x86.x86_64.run driver by forwarding my display to another computer. Somehow the AMD driver was failing to install without X screen. I created the initial xorg.conf with aticonfig. That did not work either.

I am not sure if I am hitting a bug here, or something is corrupt in my system. At this point I am out of ideas and I cannot find any leads on the web either. So SU is my last hope I guess.

Here are some logs

Xorg -configure
_XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: server already running
Fatal server error:
(EE) Cannot establish any listening sockets - Make sure an X server isn't already running(EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
(EE) Server terminated with error (1). Closing log file.

[    98.053] _XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed
[    98.053] _XSERVTransMakeAllCOTSServerListeners: server already running
[    98.053] (EE)
Fatal server error:
[    98.053] (EE) Cannot establish any listening sockets - Make sure an X server isn't already running(EE)
[    98.053] (EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
[    98.053] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    98.053] (EE)
[    98.053] (EE) Server terminated with error (1). Closing log file.

[  4717.378] X Protocol Version 11, Revision 0
[  4717.379] Build Operating System: Linux 3.12.0-rc6-patser+ x86_64 Debian
[  4717.380] Current Operating System: Linux hitit 3.12.0-customkernel #1 SMP Fri Dec 20 23:05:55 CST 2013 x86_64
[  4717.380] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.12.0-customkernel root=UUID=3ac264da-5290-4bf0-a5dc-4efb7c65e9bd ro quiet
[  4717.381] Build Date: 25 November 2013  01:54:46PM
[  4717.382] xorg-server 2:1.14.3-5 (Maarten Lankhorst <maarten.lankhorst@ubuntu.com>)
[  4717.383] Current version of pixman: 0.30.2
[  4717.385]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[  4717.385] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  4717.388] (==) Log file: "/var/log/Xorg.1.log", Time: Sat Dec 21 13:05:06 2013
[  4717.389] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  4717.389] (==) No Layout section.  Using the first Screen section.
[  4717.389] (==) No screen section available. Using defaults.
[  4717.389] (**) |-->Screen "Default Screen Section" (0)
[  4717.389] (**) |   |-->Monitor "<default monitor>"
[  4717.389] (==) No monitor specified for screen "Default Screen Section".
        Using a default monitor configuration.
[  4717.389] (==) Automatically adding devices
[  4717.389] (==) Automatically enabling devices
[  4717.389] (==) Automatically adding GPU devices
[  4717.389] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[  4717.389]    Entry deleted from font path.
[  4717.389] (==) FontPath set to:
[  4717.389] (==) ModulePath set to "/usr/lib/xorg/modules"
[  4717.389] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
[  4717.389] (II) Loader magic: 0x7fbeb4527d00
[  4717.389] (II) Module ABI versions:
[  4717.389]    X.Org ANSI C Emulation: 0.4
[  4717.389]    X.Org Video Driver: 14.1
[  4717.389]    X.Org XInput driver : 19.1
[  4717.389]    X.Org Server Extension : 7.0
[  4717.389] (II) xfree86: Adding drm device (/dev/dri/card0)
[  4717.389] (II) xfree86: Adding drm device (/dev/dri/card1)
[  4717.391] (--) PCI:*(0:0:2:0) 8086:0116:104d:907b rev 9, Mem @ 0xc0000000/4194304, 0xb0000000/268435456, I/O @ 0x00008000/64
[  4717.391] (--) PCI: (0:1:0:0) 1002:6760:104d:907b rev 0, Mem @ 0xa0000000/268435456, 0xc8400000/131072, I/O @ 0x00007000/256, BIOS @ 0x????????/131072
[  4717.391] (II) Open ACPI successful (/var/run/acpid.socket)
[  4717.392] Initializing built-in extension Generic Event Extension
  • This is totally botched. I tried every combination of ati/.amd/intel drivers situation and I am still not able to get this working. I am hoping that a genius will help me out with this ;( – kerrreem Dec 22 '13 at 6:48

Not sure if you've been able to solve the problem yet or moved on to something else, but it seems it's an issue with the newest Xorg and the catalyst drivers.

I've had success patching the catalyst driver on Ubuntu and Fedora 20, so it should work on Jessie but I have not tested it myself.

After you download catalyst, extract the .run file

open up the directory where you extracted the driver: catalyst/common/lib/modules/fglrx/build_mod/kcl_acpi.c, go to line 990 and replace all of that (to the end of the file) with:

  if (!ACPI_SUCCESS(acpi_get_table_with_size(id, 0, &hdr, &tbl_size)))
  tbl_size = 0x7fffffff;
  if (!ACPI_SUCCESS(acpi_get_table(id, 0, &hdr)))
    return KCL_ACPI_ERROR;
  return KCL_ACPI_OK;

Then use the ati-installer.sh script included with the driver to either build Debian packages, or just build and install it manually and that should work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.