Yesterday I started getting issues with AMD catalyst 13.4 (minidump of the crash was removed while restoring a restore point, I suspect). So I figured I'd uninstall 13.4 and install the latest version, 13.12. During installation I got another BSOD. I retried a few times and kept getting the same BSOD. I also tried driver versions 13.11 beta 9.5 and 13.9, but these gave the same BSODs. Eventually I installed 13.4 again, and it seemed to work properly, but today I again got a BSOD from 13.4.

I again tried to install a newer driver, but got the same BSOD during installation as I got earlier.

I've included some minidumps in a dropbox folder. Unfortunately, I can't tell which of these were caused during the installation of new drivers or by crashes from the old drivers; my minidump folder is cluttered with minidumps, and I lost a few while restoring restore points.

I've also reseated my graphics card, used a different DVI ouput and tested my RAM. There seems to be nothing wrong with the hardware. The default Windows video driver is also working without problems. The graphics card is a Club3D HD7950 RoyalKing.

When installing the driver manually, in safe mode, the installation works, but if I then reboot my PC I get a BSOD again.

2 BSODs are caused, SYSTEM_THREAD_EXCEPTION_NOT_HANDLED_M 0x1000007E and SYSTEM_SERVICE_EXCEPTION 0x3B. The former during installation, and the latter when 13.4 crashes.

EDIT: Did some more testing. Any driver newer than 13.4 won't install. 13.4 and below do install. However, it only works for about a day. Then I get a BSOD (SYSTEM_SERVICE_EXCEPTION 0x3b). And then it fails to boot, with that same BSOD.

EDIT: I just got another BSOD from atikmpag.sys, while running the default Windows driver. I've checked, and it was still in system32/drivers. I've deleted it now.

Here are the screenshots @magicandre1981 requested:

enter image description here enter image description here enter image description here enter image description here enter image description hereTwo of those are in my PC, slot 2 and 4

enter image description here Microsoft Basic Display adapter, because I had to remove the faulty driver.

enter image description here

  • update the UEFI/BIOS to Version 2 (from 1.70). Also make sure the commandrate RAM is set to 2 instead of 1. This can also cause wired crashes. Also Which PSU do you use? Can it handle the required W? – magicandre1981 Dec 22 '13 at 18:13
  • @magicandre1981 I can't seem to find the BIOS update. Have you got a link? How would I check what my current BIOS version is? And where would I find the commandrate setting? My PSU is an XFX Pro 550W. The graphics card's requirements state that it needs a PSU of at least 500W – Simon Verbeke Dec 22 '13 at 18:22
  • I looked at the dump and here I can read the version. This is the link: asrock.com/mb/Intel/Z77%20Pro4-M/… – magicandre1981 Dec 22 '13 at 18:24
  • @magicandre1981 aha, I thought you were talking about the BIOS of my graphics card. I'll install this and post an update. – Simon Verbeke Dec 22 '13 at 18:26
  • 1
    @techie007 Installed W8 on another partition, and catalyst 13.12 installed without issues. Will be running a stress test now, to see if that causes any issues. – Simon Verbeke Dec 25 '13 at 1:42

Although it seems like a hardware problem to me (from here, without seeing it ;) ), you'll still want to discern if it's hardware or software that's causing the problem.

If you want to eliminate software, reinstall your OS (or install a fresh test copy on a different drive).

If you want to eliminate hardware, then you'll need spare parts to start swapping in and out.


If you have an alternate card(integrated graphics card, IGD) in your system then first goto your bios and restore all settings (default bios settings) and then boot from that card (i.e. go into your BIOS ,as I don't know your bios I wouldn't be able to tell you exactly, and then go to video options that lets you to determine which card you want to use during Boot process). If this works (which I hope should work and as you also said that "The default Windows video driver is also working without problems" as these drivers work on an integrated card) then it should not be a problem of your graphics driver. First try to update your BIOS (it's for if this is your first BIOS update) and always boot from IGD into your windows. Then first change your preferred screen to the other screen (Screen using your AMD graphics card) and then try to change your screen to another input (I assume that your monitor accepts multi-inputs). You should always do this and if you want to boot from AMD graphics card you can change it anytime, but since it crashes most of the time, I recommend you to use this method for some days(1 week or so) and then change your default Graphics card during boot. choose screen from here Screen 1 Screen 2

screen 1 uses IGD. screen 2 uses Nvidia card.

  • Thanks for the suggestion. However, I tested a clean Win 8 install before seeing your answer. And it seems there was just something wrong in my OS. So I can't see if your suggestion actually works. – Simon Verbeke Dec 26 '13 at 1:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.