17

I just downloaded and tried to add new virtual machine, but it gives me an error. I couldn't find the solution. it seems that VM can not find the OS. I don't know how to resolve.

Error is:

FATAL: No bootable medium found! System Halted.

I have Vista and latest version of Sun VirtualBox.

3
  • First get an MD5 sum of the ISO and check it against the md5 provided by ubuntu to make sure the ISO is not corrupt. You have the guest additions loaded as an IDE drive. Can you remove it in case it is trying to boot from it.
    – Paul
    Oct 28 '11 at 4:36
  • I just needed to remove an empty item in the list of connected storage devices, and after the ISO was right under the main hard disk drive, everything worked fine.
    – GDP2
    Oct 24 '18 at 9:20
  • Related post - What does “No bootable medium found” mean in VirtualBox?
    – RBT
    Jan 29 '19 at 12:16

11 Answers 11

9

This is now working fine. The virtual machine should point to the .iso image of the OS. This can be done by following steps:

In the Virtual Machine window (where this error is appearing), go to "Devices" tab --> CD/DVD Devices --> More CD/DVD images --> select the location where the .iso image for this OS is stored.

Now Power off the machine and again start from the Virtual box. Your Machine should start.

4

The reason that VirtualBox can't find the OS is that there is no OS.

In order to boot a virtual machine to an OS, you have to install an OS first by mounting an ISO or physical CD with a bootable OS install (eg, an Windows or Linux installation disc)

3
  • 1
    Can you tell me whats wrong with my settings: screenshot I am trying to install it from ISO, but it is giving me "No bootable medium found error" when I boot up the VM in virtual box.
    – Maha
    May 7 '17 at 20:18
  • Why isn't this done during the generic setup routine...
    – ucb
    Oct 15 '19 at 14:21
  • @unami: Because operating systems are not generic.
    – SLaks
    Nov 6 '19 at 21:59
4

Hi the Answer is simple.

Go to settings > Storage > Storage Tree

and mount your image/CD/DVD drive under Controller: IDE (Don't use SATA)

Either add a new CD/DVD device or use the existing one.

3
  • 2
    The important point is to use IDE as for some reason it does not work with SATA.
    – Chris
    Oct 23 '14 at 8:44
  • SATA works if it is the first controller. It won't work if the first controller is IDE. I don't know why, maybe someone is able to explain this strange behavior.
    – scai
    Sep 4 '16 at 9:49
  • by which IDE you're talking about? there are PIX3 PIX4?. both of them didn't work in my case. and my ISO is just fine. its running on vmware but not this vbox Nov 7 '20 at 4:56
2

When you first create a Virtual Machine with VirtualBox, there is no OS installed on the HD image. You have to have the VM mount a bootable ISO image to install the OS from.

2

In my instance, I needed to have two .iso images attached as optical devices during an install. I found that after adding the second image to the IDE controller, VirtualBox ceased to recognize the first image as bootable.

After much trial and error, I was able to boot once again by choosing Settings > Storage, selecting the bootable .iso image and changing its attributes to IDE Primary Slave.

For what it's worth, I also had to change the attributes of the other .iso image device to IDE Secondary before the Primary Slave option was available for the bootable image. I imagine the order in which you add the images to the storage tree may determine which attributes are assigned to them.

1
  • This is essentially what my issue was. I had an empty item in the list, and the removal of it fixed the problem.
    – GDP2
    Oct 24 '18 at 9:22
1

Try this:

  • "Devices" → "Optical drives" → "SATA (SATA Port 1)"
  • Choose disk image (your .iso OS)
  • then "Machine" → "Reset"
0

This is normal. You need to load a medium (normally, the ISO file of a bootable CD or DVD) into your virtual machine. Your DVD software might be able to create an ISO file of your Vista DVD. Otherwise, use a Linux distribution, for example Knoppix for a first boot.

2
  • 2
    An ISO isn't strictly necessary, since you can configure VBox to boot from the actual dvd drive. So if you have a bootable CD/DVD, you should be good. That said, installing from an ISO file is much quicker. Nov 11 '09 at 23:47
  • Good to know! -
    – Pekka
    Nov 12 '09 at 1:34
0

Solution: Try a different architecture type of iso.

I was able to solve this problem by changing the ISO image. I was trying to install cent os 7 with virtual box on mac 10.11.6 (el-capitan ). First I had downloaded the minimal set up from here: https://wiki.centos.org/Download

There are setups available for different architecture types. I first tried with aarch64. But could not get past the same error: Fatal: no bootable medium found! System Halted

Tried everything but never solved. Then I tried "i386" . And it worked.

0

New MacOS Operative System are not ready out of the box.

My solution was to get rid of the Catalina.iso, then:

  1. Download an High Sierra.app
  2. Turn it into an High Sierra.dmg
  3. Turn it into an High Sierra.iso
  4. Select "High Sierra" from the out-of-the-box dropdown menu at the beginning of the setup page

enter image description here

Newer OS like Mojave or Catalina are not ready yet, they will probably be ready in a few months/year. This is the price to pay for free software.

0

I was installing Windows XP via VirtualBox using the "Windows XP Mode" official release from Microsoft, which gives you a VirtualXP.vhd virtual hard disk file.

In the setup wizard, the default choice is:

Create a virtual hard disk now

I selected this and created a virtual hard disk. I thought I had already selected and used the downloaded file on the first page of the wizard.

But you'll get the FATAL: No bootable medium found! System Halted. error when you run the VM.

Instead, in the situation where you are booting off a provided .vhd rather than a .iso, you should select:

Use an existing virtual hard disk file

and click the folder icon to select the .vhd file you are trying to load.

Now your downloaded .vhd is the "bootable medium", and VirtualBox won't be looking for a .iso or CD drive to load.

boot from .vhd

0

If you added the iso file but its still not working, then if there is a file named "empyt", make sure to remove that attachment.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy