I have installed Ubuntu 12.04.3 on one of my old computers in order to use it as a web server. I installed openssh. Ive installed webmin but cant access it. Matter of fact I cannot remotely connect to the server at all after setting up ssh (without keys at this point).This is my first time doing something like this so sorry for the lack of info and my newb skills, but any other pointers/tips links to guides are very welcome!

I have set up a root password and also I have allowed password access.


I have a network connection (it is static to a reserved ip), i can wget etc. i have already ran "apt-get install -f" and all the necessary packages are installed for webmin. Ive configured port forwarding like so:

http tcp 80 80 ssh tcp 22 22 ftp tcp/udp 21 21

all with the local ip of my server (

So now I'm still not able to connect to the server with ftp or ssh. if i go to the ip port 80 in a browser it just keeps tying to load something (so isn't this a sign of life maybe?). If i access using the local ip from inside my network it goes to the "It Works" default page. I also can access webmin using local ip.

Using canyouseeme.org I found out that port 22 and 80 are both visible and not blocked, port 21 came back as connection refused.

I found my answer and answered my question below.

  • You are using port 10000 right? localhost:10000 or substitute your IP address for localhost. The standard webserver is apache make sure that is installed also. – cybernard Dec 23 '13 at 6:46
  • yes i do have apache2 installed and im using port 10000 – cbalos Dec 23 '13 at 8:58
  • webmin has it own webserver. Put apache back to port 80 or some other port just not 10000. If that does not help then you might have a firewall in place. what is the result of iptables --list – cybernard Dec 24 '13 at 4:02
  • sorry i i think i misunderstood you, i didnt change the apache port. Apache default is port 80 correct? – cbalos Dec 24 '13 at 5:33
  • yes the default port is 80 – cybernard Dec 24 '13 at 14:39

Quick check list:

Is your server able to talk to the outside world? (eg: ping, wget etc.)
If not and you've set your server to use a static ip, change it back to dhcp and try again.
If this works, just lock the ip in your router settings instead of on the server.
If this still doesn't work... Do you actually have a network connection? (whole other world of trouble)

Next try connecting to your services from inside the same network before using nat etc.
And after that you might run into your isp blocking incoming ports...

Now you say you've set up webmin but if you've just ran "dpkg -i webmin*.dpkg" then you most likely still need to run "apt-get install -f" to fix some packets missing from the standard ubuntu install.

I hope this helps...

ps: For port forwarding and general network help check: http://portforward.com/

  • This was very helpful. But yes i have a network connection (it is static to a reserved ip), i can wget etc. i have already ran "apt-get install -f" and all the necessary packages are installed. Check my edited question now for updated/more info – cbalos Dec 23 '13 at 8:34
  • Ok, so you can you access everything from inside the same network as the server? For port forwarding and general network help check: portforward.com – HTDutchy Dec 23 '13 at 8:39
  • yes if i access with the local ip from inside my network, I get the "It, works!" default page – cbalos Dec 23 '13 at 8:49
  • Good! now for forwarding I think it's better to check out a manual for your router at portforward – HTDutchy Dec 23 '13 at 8:51
  • So you think its a port forwarding issue then? – cbalos Dec 23 '13 at 8:56

So I think I may have found out the problem here: http://ubuntuforums.org/showthread.php?t=2171737

I can connect to my server over the public ip as long as I am not in the local network. I need a router that is configured/has nat loopback to access the server with my public ip while on my local network. For anyone else with the issue you can read why here also: https://en.wikipedia.org/wiki/NAT_loopback#NAT_loopback

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.