I've been running a small personal server for my own needs for a couple of years on an old computer that I got for 2 chocolate bars from a friend. I installed xubuntu since the machine was old enough not to support ubuntu server distro. It was fine, though, since I mostly used to test my own web projects before I put them in production.
Last week, I couldn't load my web site and when I grabbed the server box and hooked it up to a monitor after a restart all it said is that it printed out terminal not found and had reverted to busybox.

I did not panick, burned a copy of Damn Small Linux on a CD, tried to run it as a liveCD but failed with kernel panic; vfs unable to mount root fs, I then attempted to run an xubuntu liveCD but it failed with an "I/O Error reading CD" error.

Since I have a IDE to usb cable, I booted up the same xubuntu on my windows7 machine, connected the HDD through USB and it then recognized the HDD. Some progress, but, sadly, it was not able to mount it. It basically shows the drive icon on the desktop as it recognizes it but when I try to mount it an error pops up that it can't do it. fdisk -l shows only my internal HDD.

I am out of ideas on this one, so I'm turning to you guys - what are my chances? What else could I try? Will add any information requested ASAP since I know my error message descriptions are vague (typing them from the top of my head, sorry).

All I need to do is get the image of the servers HDD really, I have a spare one to replace it.

Thank you for your time.


I have just mounted the servers HDD to my win7 machine and it works great. Two questions remain:

  • If I make an image and try to restore it on another drive - is that even possible due to it being a different drive (hardware being different) or that doesn't affect anything?
  • If I succeed to restore the drive image, I reckon that the problem with the OS not being able to boot will still persist?

You should burn to a USB stick an image of Ubuntu, (other choices are possible, see this Web page for more suggestions but discard Kali Linux a,d BackBox as unsuitable), boot from the USB, choose Try Ubuntu without installing, download SMART,

  sudo apt-get install smartmontools

then check that your disk supports SMART,

  sudo smartctl -i /dev/sda 

(if it does not, this

  sudo smartctl -s /dev/sda 

will enable smart spport), then let it run the long form of the test:

  sudo smartctl -t long /dev/sda 

This will provide a good basis for further action.

  • I did, at first, try to boot from a flash drive, but after not succeeding and checking BIOS settings it seems that it doesn't support booting from a USB stick, that's why I reverted to a CD and that didn't succeed as I said above – Pankucins Dec 23 '13 at 17:47
  • What is the stick filesystem? Pcs can boot only from FAT – MariusMatutiae Dec 23 '13 at 17:49
  • Well, I tried to boot the pendrive on the linux machine using a bootable usb created by Pen Drive Linux app (pendrivelinux.com/universal-usb-installer-easy-as-1-2-3). Also, I did what karel suggested and I have mounted the drive successfully, so I reckon I will make an image of it and switch it with the other drive I have. – Pankucins Dec 23 '13 at 18:07

It is possible that your hard drive is in OK condition and the reason why Windows 7 is displaying an error message when you try to mount it is because the hard drive is formatted as ext3 or ext4 or some other filesystem format that Windows does not support natively. If so, you can solve this problem by installing a Windows file system driver for the Ext2, Ext3, and Ext4 file systems application, such as Ext2Fsd, DiskInternals Linux Reader or Ext2explore. You can find detailed descriptions and screenshots of these three applications in the How-To-Geek article: 3 Ways to Access Your Linux Partitions From Windows.

Also it would be a good idea for you to get the image of your server from the hard drive before you subject the hard drive to any other sustained heavy usage.

  • Thank you very much, I somehow didn't find this but I have just connected the drive and it works! – Pankucins Dec 23 '13 at 18:08
  • If this answered your question, you may mark this answer as accepted by clicking the gray check mark to the left of it. – karel Dec 23 '13 at 18:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.