0

I get Batman GOTY edition, but I can't run it: I have something like 1 or 2 FPS or I get the error ?FRA?Launch.Errors.Error.FailedToCreateD3D9Device?, it depends on the selected driver.

As far as I understand, they are 2 GPU in my Laptop : the Intel HD 4000 and the AMD Radeon HD 7670M. The first one is used when normal tasks are performed (FF, OOo...), and the second one is used only on heavy tasks such as Gaming. I get 2 FPS when the computer does not switch the GPU (he keep the Intel), and the error because of driver issues. Apparently the drivers does not support W8.1.

WHAT I HAVE DONE :

I didn't write all that during my manipulations. So I may have forgotten some part or be mistaken.

  • I installed DirectX. It said that I have already installed it.
  • I burnt a CD with my documents (just in case).
  • I made a Recovery Key when I received my laptop,? Unfortunately, I don't know why, it worked for a while but it is no more recognized by the BIOS.
  • Update GPU driver :
    • Using SW Update. I got an error (-10).
    • Using SW Update, but in the section Find a model, and then Download the Config file for my laptop, I got a folder on my desktop, with the driver AMD 13.152.1.2000 (471MB), with folders and a file, Setup.exe (which I ran). When rebooting, I got a black screen, where I can move the pointer. It kept black, and sometimes I saw for a second parts of the UI (Wifi...). The lights kept on, and the computer worked, only the screen mattered (when I disabled the touchpad using Fn keys, I couldn't move the pointer using the touchpad no more). I am forced to make an hard a reboot in Safe Mode and change drivers. That let me think that this is because of the GPU Driver.
    • Using the Windows Drive Manager, then GPU, AMD Radeon 7670M, Driver, Update. Didn't work I think.
    • Using the latest beta drivers. The version 13.250.18.0 (29/11/13) didn't work. Black screen I think.
    • for the Intel Card. Went on Intel's website, problems while installing (it said that I ought to use manufacturer's wizard)
    • Using Samsung Website. Didn't worked.
  • Ran AMD CAtalyst Center : no parameter configured.
    EDIT#1
  • W/o doing anything, a error popped up saying Catalyst Control Center has stop

DRIVER VERSIONS RELEASE DATES

  • AMD 9.12.8.0 : 11/02/13 : before handles
  • AMD 13.152.1.2000 : 18/09/13 : downloaded from Find a model in SW Update
  • AMD 13.250.18.0 : (29/11/13) : latest beta driver (mobility)

DRIVER VERSION COMBINATION

Pattern : Intel Driver Version Asked + AMD Driver Asked (= Intel Version Got + AMD Version Got) = Result

  • Microsoft Defaut Driver + AMD v9.12.8.0 = Black screen at startup
  • Microsoft Defaut Driver + AMD v13.152.1.200 = Black screen at startup
  • Microsoft Defaut Driver + AMD v13.250.18.0 = Black screen at startup
  • Intel 4000 v8.982.6.0 + 13.250.18.0 = Intel 4000 v8.982.6.0 + ??? v8.982.6.0 (detected as amd but same version as Intel) = start properly but D3D9 failed when running BM GOTY.

MY CONFIG

Go here on my-config.com

NB : I am french so translations of names can be false.

0

Thanks for your help. I downloaded the driver 13.12 WHQL from here, and after a complete uninstallation using AMD Wizard + CCleaner, I installed it. The Intel didn't worked (it was not recognized), but the AMD was succesfully installed and I can now play !!!

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.