1

When I tried to install the package liblog4cxx10-dev, it reports the error as follows:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 liblog4cxx10-dev : Depends: libaprutil1-dev but it is not going to be installed

E: Unable to correct problems, you have held broken packages.

My system is Ubuntu 12.04 LTS 64bits. I googled and checked the

apt-cache policy libblog4cxx10-dev

**The result is:

 liblog4cxx10-dev:
  Installed: (none)
  Candidate: 0.10.0-1.2ubuntu2
  Version table:
     0.10.0-1.2ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/universe amd64 Packages

If I use apt-get install to install libaprutil1-dev, I have the errors as follows: The following packages have unmet dependencies:

libaprutil1-dev : Depends: libsqlite3-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Could anyone help by letting me know how to solve the issue? For example, which tools I should use or which file I should check?

Thanks in advance!**

0

First run apt-get autoremove to remove the broken packages and apt-get update to refresh. Finally, try your original apt-get.

  • Thank you for your advice. I tried, but it still has the same error. :( – Mike Dec 29 '13 at 19:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.