I have a Netgear FVG318v1 router and all computers on the network cannot play any YouTube videos. I have tried with 3 computers, PC and Mac with all different kinds of browsers. All I get from YouTube is static and "An error occured, please try again later"

Googling yielded that this seems to be a common problem with that kind of router and some people apparently had MTU issues. I tried several MTUs btw. 1500 and 600 with no luck. I also update the router's firmware to the latest one just now.

I am at my wit's end. Any ideas would be greatly apppreciated!

  • 1
    if you skip the router and hook a computer directly to the Internet, does YouTube work as expected? Dec 24, 2013 at 17:13
  • Do you control the router? Could you possibly be blocked by your ISP? If you have any such doubt, you may want to try a quick VPN solution, by Googling Hola Unblocker, it takes 30 seconds to set it up and might help you. Dec 24, 2013 at 18:58
  • I can't test going directly but I suppose it would work. I do control the router, yes. Tried Hola but that doesn't seem to do anything. I'm pretty sure it's something in the router. Just installed Wireshark and every package from outside the LAN comes back with a 0x0000 checksum. Could the router be stripping checksums? And could that possibly affect YouTube? Because everythign else is working fine. EDIT: It somehow mixed up my accounts it seems? Anyway. Same guy. Dec 25, 2013 at 10:56
  • Oops, sorry. I'm sending those 0x0000's out. In that case it's OK, I guess. So please forget about the checksums. Dec 25, 2013 at 11:24
  • Sorry for the post on post but I think I'm on to something. Maybe Wireshark was a little too low. Firebug gave me and idea what my browser is trying to do. It is trying to get the video from r8---sn-xjpm-q0ns.googlevideo.com, which is not pingable from behind or inside my router. However this address is pingable through an online ping thing (I used ping.eu). Now, is it possible that my router (a 2006 model) does not support that type of URL? What is it anyway? Looks like an IDN but doesn't seem to be one? Dec 25, 2013 at 12:08

2 Answers 2


Try doing a traceroute to that hostname and check for circular routing. I am having the same problem right now with a RV082 and have a ticket in with my ISP.

In my case the hostname is r1---sn-3ovavbt-5bne.googlevideo.com

Edit: confirmed routing issue with my ISP, they fixed it and is working now.


Try using a different browser. I have had this problem when using Chromium for example. I understand that this may not be a complete solution but try opening a Youtube video that doesn't work in another browser.

For example, some Youtube videos don't work in Chromium for me (I'm on Ubuntu 12.04), while they open and work fine in Firefox.

  • Sorry, like I said above, no OS or browser works. Not even my phone is playing YouTube videos when connected to wireless. Dec 25, 2013 at 11:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .