I have a 32 GB Lacie Cookey USB flash disk that doesn't show in the Computer window but it's visible as a device.

cmd > diskpart

DISKPART> list disk

  Disk ###  Status         Size
  --------  -------------  ------
  Disk 0    Online          149 G
  Disk 1    No Media          0

DISKPART> select disk 1

Disk 1 is now the selected disk.


Virtual Disk Service error:
There is no media in the device.

It also appears in the Disk Management tool, but the box is empty.

Is there anything I can do or is it dead?


output from ChipGenius:

Description: [F:]USB Mass Storage Device(LaCie CooKey)
Device Type:        Mass Storage Device

Protocal Version: USB 2.00
Current Speed: High Speed
Max Current: 200mA

USB Device ID: VID = 059F PID = 103B
Serial Number: 070535924B170C18

Device Vendor: LaCie
Device Name: CooKey
Device Revision: 0100

Manufacturer: LaCie
Product Model: CooKey
Product Revision: PMAP

Controller Vendor: Phison
Controller Part-Number: PS2251-67(PS2267) - F/W 06.08.53 [2012-09-26]
Flash ID code: 983AA892 - Toshiba [TLC]

Tools on web:       http://dl.mydigit.net/special/up/phison.html

Looking at the Chipgenius Dump, it is a Phison Controller.

You can try the following steps one by one and check if any of them helps:

  1. Download Rufus or Bootice and try formatting your USB drive in Windows.
  2. If above step does not help, connect the USB Drive to Linux Operating System and check if you can access the files. If you can, copy your files and format the drive in Linux using Gparted or Disk Utility.

If the above two don't help, then try this: download Phison Mass Production tools for your USB Drive from http://flashboot.ru/files/phison/ and try formatting your USB Drive. You will have to try with each tool until you succeed. This tool will try to reprogram your USB Drive's Microcontroller and format it again. NOTE - This will delete all the files in your USB Drive.

Check this link for a detailed guide on how to do this (in this guide the MPtool is being used to repair a fake USB Drive): http://agnipulse.com/2010/04/how-i-fixed-a-fake-64gb-usb-drive/

Look at these answers for details on Mass Production tools: Flipping the Removable Media bit -- alternatives to BootIt? and How to format/repair a write-protected USB drive with I/O errors?

Hope this helps. Let me know how it goes.

  • The Bootice links are all dead, but Rufus works still. I believe I got into this scenario after converting the flash drive to a bootable device (and long since forgotten since now I wish to reuse it for another purpose), reformatting and selecting "MBR partition scheme for BIOS of UEFI computers" seems to have fixed my problem.
    – aolszowka
    Dec 2 '14 at 0:56
  • Wow, I repaired my drive with the 1st mpall from flashboot.ru, I had to go to advanced settings and choose the options based on chipgenius data (I chose no firmware on IC FW), my drive is a kingston DTMC3/64GB with phison controller, first it was readonly, then it was showing that I had to insert a disk. All this started after the driver froze during a file write after 2~ hours of use. Also chipinfo data wasn't shown on a 3.0 port, had to connect the drive in a 2.0
    – Dan
    Mar 16 '17 at 7:27

Do you have the proprietary driver software installed? This should be it: http://www.lacie.com/support/drivers/driver.htm?id=10253

Also, make sure Windows update isn't automatically replacing it with the default "Mass Storage Device" driver.

  • it doesn't even show up in "devices and removable storage". but it does show up in "devices and printers" as "cookey"...
    – marie
    Dec 25 '13 at 17:19
  • Does it work on other machines? Do other USB flash drives work on your computer?
    – PFitz
    Dec 25 '13 at 22:44


I tried everything, I mean everything. Finally I downloaded Jetflash application above and it actually worked and saved myself a 16GB memory stick.

  • JetFlash Online Recovery is an advanced new software tool specifically developed for Transcend JetFlash USB flash drives. Are you sure it will work for any USB flash drive? Nov 24 '14 at 2:27
  • I tried absolutely everything and I was ready to buy a new USB flash drive, but I read somewhere that somebody had a very similar problem and it worked for them and I had nothing to lose. My drive was a Centon Datastick Pro 16GB. I am also very concerned about viruses and I scanned the app before and scanned my computer twice afterwards including various reboots just to be careful. My system and USB are working fine. I hope this helps someone else.
    – Damion
    Nov 24 '14 at 3:29

When there is a “No Media” error message, it basically means that the USB flash drive isn’t in full contact with the USB socket. Sometimes the USB access/power light may come on even when there isn’t full contact on the two D+ and D- pins, or pin 2 and 3 of the A connector.

Try the drive in another USB socket, a USB hub, or use a USB extender cable. A USB extender cable usually lets you see if the 2 holes on the sides of the type A male connector mate completely with the 2 fingers on the female type A socket.

When the USB connector and socket mate completely the USB flash drive should appear.

Not the answer you're looking for? Browse other questions tagged or ask your own question.