53

I've got a bunch of ts segments described by a single index.m3u8 file:

index.m3u8        
segment1_0_av.ts  
segment2_0_av.ts  
segment3_0_av.ts  
segment4_0_av.ts  
segment5_0_av.ts

I know they are all encoded the same way. ffprobe gives me the following:

Input #0, mpegts, from 'segment1_0_av.ts':
  Duration: 00:00:10.00, start: 0.100511, bitrate: 1251 kb/s
  Program 1 
    Stream #0:0[0x100]: Video: h264 (Main) ([27][0][0][0] / 0x001B), yuv420p, 960x540 [SAR 1:1 DAR 16:9], 12.50 fps, 25 tbr, 90k tbn, 25 tbc
    Stream #0:1[0x101]: Audio: aac ([15][0][0][0] / 0x000F), 44100 Hz, stereo, fltp, 105 kb/s
    Stream #0:2[0x102]: Unknown: none ([21][0][0][0] / 0x0015)

I'd like to combine them into a single mp4 container. But when I try commands like:

ffmpeg -f concat -i filelist.txt -c copy output.mp4

where the generate the filelist.txt from the index.m3u8 file, it complains about not being able to read various files. But converting the ts files themselves seem to work fine. I think I'm not using ffmpeg properly.

How do I use ffmpeg to combine the ts files described by index.m3u8 into a single mp4 container using the copy codec?

65

I'm not sure why ffmpeg is giving you an error. However ts is one of the few formats that can simply be concatenated. Then, once you have a single ts, transmux to mp4.

Under windows:

copy /b segment1_0_av.ts+segment2_0_av.ts+segment3_0_av.ts all.ts
ffmpeg -i all.ts -acodec copy -vcodec copy all.mp4

Under GNU/Linux, using bash:

cat segment1_0_av.ts segment2_0_av.ts segment3_0_av.ts > all.ts
ffmpeg -i all.ts -acodec copy -vcodec copy all.mp4
| improve this answer | |
  • 12
    You may also need -bsf:a aac_adtstoasc. – Camilo Martin Jul 3 '16 at 20:38
  • 1
    interesting to note that the command is NOT ffmpeg copy ..., it is copy ... (under Windows) – Ronnie Royston Apr 4 '18 at 18:07
33

Using copy or cat to combine the files like szatmary's current top answer might leave you with a file that plays far past the limit and can't seek along with playback issues.

Instead, to combine these files properly use ffmpeg as instructed in https://trac.ffmpeg.org/wiki/Concatenate. (Install ffmpeg here if you don't already have it https://github.com/adaptlearning/adapt_authoring/wiki/Installing-FFmpeg.)

If you're too lazy to read my first link, you basically have to create a .txt file listing all the files you want to combine like so (which my first link gives instructions on how to do easily) in the folder where you're doing the concatenation:

file '/path/to/file1'
file '/path/to/file2'
file '/path/to/file3'

Here's a copy paste from my first link on one way to create a text file if you have Windows on commandline for instance but obviously you can make the file manually or however you want:

(for %i in (*.ts) do @echo file '%i') > mylist.txt

Double check that your .txt file looks good and is formatted correctly!

After this, on commandline run:

ffmpeg -f concat -i mylist.txt -c copy all.ts

where 'mylist.txt' is the .txt file you just made.

Check if the resultant file plays video correctly. From here, you can transmux to mp4 as usual if you like:

ffmpeg -i all.ts -acodec copy -vcodec copy all.mp4
| improve this answer | |
  • That for %i in (*.ts) do doesn't sort correctly for i >= 10. Apart from that, everything works, thanks. Indeed, there were problems with the concatenated file, not to mention that the file made using your method has turned out to be 16% smaller (I had 1400 parts by 400kb). – user Mar 24 '19 at 6:20
  • @user for numbers in order you can iterate through numbers like for i in {1..10}; do echo file \'$i.ts\' >> list.txt ; done – qwr Nov 13 '19 at 3:21
  • For me this causes an audio stutter at each join point, whereas the accepted answer doesn't. The resulting file is also marginally larger with this method. – markshep Jun 1 at 22:52
8

2017 answer

But when I try commands like ..., it complains about not being able to read various files.

When I execute ffmpeg -i some.ts -c copy some.mp4 on a certain video, I get this error message:

Malformed AAC bitstream detected: use the audio bitstream filter 
'aac_adtstoasc' to fix it ('-bsf:a aac_adtstoasc' option with ffmpeg)

av_interleaved_write_frame(): Operation not permitted

Not surprisingly, executing ffmpeg -i some.ts -c copy -bsf:a aac_adtstoasc some.mp4 fixes it.

| improve this answer | |
  • 4
    Get a new enough ffmpeg and it will now do this automatically. – llogan Nov 11 '17 at 18:40
7

Putting all together

Using the Juan Aquino's answer (and correcting the first command to be compatible with Bash and using the natural ordering of files), plus the 7vujy0f0hy's answer, a simple working script for a Linux Bash shell is:

#!/bin/bash
for i in `ls *.ts | sort -V`; do echo "file $i"; done >> mylist.txt
ffmpeg -f concat -i mylist.txt -c copy -bsf:a aac_adtstoasc video.mp4
| improve this answer | |
7

The correct way to concat multiple video files from m3u8 playlist is

ffmpeg -i "index.m3u8" -codec copy output.mp4


  • the m3u8 playlist can be on web or locally in directory
    • it contains list of file paths relative to the playlist
  • -codec copy to avoid encoding
  • container type matters:
    • *.mp4 is fine but it seems little slow to mux when playlist is fetched from web
    • *.mkv or *.ts worked best for me
| improve this answer | |
2

You can do the concatenating simple like so (with bash):

for f in ./{0..<number>}.ts; do cat $f >> out.ts; done

Replace <number> with the highest number (obviously). The variants with ffmpeg didn’t work properly. The output video file would stutter weirdly.

I use the for loop to ensure the correct order of the files. Maybe you don’t need it. Maybe it’s even possible to pipe the output to ffmpeg and convert it to mp4 on the fly.

| improve this answer | |
1

You can use pipe these ts files in to ffmpeg and output the mp4 file.

cat *.ts | ffmpeg -i pipe: -c:a copy -c:v copy output.mp4

or If you ts file name not have order,

grep .*.ts index.m3u8 | xargs cat | ffmpeg -i pipe: -c:a copy -c:v copy output.mp4

| improve this answer | |
0

All the popular answers to this question that mislead readers to concatenate the TS files before running ffmpeg are incorrect. To ensure the audio and video do not fall out of sync during the assembly of the mp4 stream, the poorly documented but important "-f concat" feature of ffmpeg should be used.

    delimiterBeforeFileNumber="-"
    ls |egrep '[.]ts$' \
        |sort "-t$delimiterBeforeFileNumber" -k2,2n \
        |sed -r "s/(.*)/file '\1'/" >ts.files.txt

    ffmpeg -f concat -i ts.files.txt -c copy tsw.014.ts.mp4

The two preparatory lines of code just create a file containing a list of TS files in this line format:

    file 'seg-37-a.ts'
| improve this answer | |
  • Actually, when I tried this, there was a slight "stutter" between the segments in the final video. So at least in that one case it helped concatenating the TS files first. – Sphinxxx Jul 31 '19 at 18:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.