I'm using Cygwin on Windows because some commands in Windows's CMD are not working but working on terminal of OS X and Linux. When I type the wget command and URL, it says command not found. Is there any suggestion to fix this.

enter image description here

  • 1
    Are others commands, like ls, works fine ? Dec 26, 2013 at 13:05
  • @user2196728 I'm completely new to Cygwin so I know just cd command is working Dec 26, 2013 at 13:13
  • Have you tried using curl?
    – dillmo
    Dec 30, 2013 at 16:13
  • 1
    @dillmo technically he hasn't really even tried using wget, he hasn't even realised that he isn't executing it!! or he has realised it and he hasn't thought to look for wget.exe on his system. I don't think him trying curl would help him!
    – barlop
    Dec 30, 2013 at 16:40

2 Answers 2


The wget command is not installed by default in Cygwin. To install wget, re-run the Cygwin setup and select the wget package:

wget utility in package list

If wget is selected to install, the screen should look like this:

wget utility selected to install

Click next to complete the installation and run wget using the Cygwin Terminal or Cygwin64 Terminal (if you have installed the 64-bit version).

  • 1
    you may find wget under Web instead of Net on newer versions of cygwin Mar 29, 2016 at 23:48
  • As of Windows 10 (version 1803), if you need a HTTP client, curl is now installed by default. On PowerShell, wget is also an alias for Invoke-WebRequest. Jun 21, 2018 at 15:22

Here is an alternative to yjwong's answer, even if it is not a direct answer to your Cygwin problem, it is a Cygwin alternative.

Usually, when i need to take advantage of the power of Linux commands under Windows environnement (for one shot purpose or batch scripting) i don't use an overkill such as Cygwin. I just use UnxUtils.

It provides a lot and main common used Linux commands. These commands run as stand-alone exe files, with no need to install anything on Windows machine.

This is also true if you only need the wget command.

The download link is here.

Trying it often means adopting it, in most cases :)

  • it is not working :( Dec 26, 2013 at 15:01
  • what did you try ? open a cmd Windows, then cd to UnxUtils wbin folder, then type wget www.yahoo.com Dec 26, 2013 at 15:02
  • 2
    I realize this is old, but I'd just like to point out that if you'd like to be able to run one Linux command line tool on Windows, it's likely that over time you'll want to run others. And while UnxUtils has a fair number of tools, it's just a "very" small drop in the bucket compared to what Cygwin offers. While being native ports in principal makes them faster than the emulation of Cygwin, in practice I've never found performance to be an issue with Cygwin - and unlike UnxUtils, Cygwin offers very exact and complete fidelity with GNU/Linux.
    – sootsnoot
    Jul 21, 2017 at 2:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .