1

I've got a router far from the room I use as an office. I've got a Gigabit Ethernet cable from there that goes to a switch and then to several computers/devices. Now I'd like to have a secondary WiFi network for my office.

I've connected the router to the switch, deleted its WAN settings, and configured it as an Access Point. The wireless network is seen -- for example, by my laptop -- but there's no Internet access.

I guess I must add some routing, but I've tried and didn't succeed. The control panel of this router (a Comtrend AR-5381u) on this part is as follows:

enter image description here

But I've messed up with the prefix, and I'm not even sure that's the part I must modify.

To clarify:

  • Main Router: 192.168.1.1, WiFi SSID "House", DHCP enabled (192.168.1.33-99)
  • Secondary Router: 192.168.1.2, WiFi SSID "Office", DHCP enabled (192.168.1.25-32)

What am I missing?

  • 1
    It might not be your problem, but you have network address range overlap between the two separate networks. That will almost certainly cause you headaches, if not now then further down the road. I'd strongly suggest moving one of them to a different subnet range; for example, use 192.168.1/24 for "House" and 192.168.2/24 for "Office". It's either that, or run them as a single network, in which case you should disable the DHCP server on one of them and only connect to an AP on that side. – a CVn Dec 26 '13 at 15:30
  • 2
    In my experience, the 'easiest' way to do this is to either turn off DHCP on the second router, and connect a lan port on the primary router to the secondary router or to have the secondary router on a completely different subnet, and plug a lan port from the primary router to the internet port of the secondary router. You shouldn't need to add static route at all. – Journeyman Geek Dec 26 '13 at 15:33
1

The only part I see "missing" here is the secondary router having the primary router address entered as its gateway. That would actually be on the "default gateway" page rather than needing to add a route.

Prefix length will be 24.

There is no problem with having two DHCP's if they don't overlap and both have the correct gateway defined.

There is no problem having two access points on the same network (and considerable problems/weird behaviors from having two networks when you really only want one)

0

Disabling DHCP on the second router, as Michael and Journeyman said, was the key. Fantastic! ;) I thought that second network should have its own DHCP server, but I was wrong, obviously.

Thanks!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.