0

I'm having trouble discovering UPnP/DLNA devices on my network. Discovery seems to be unreliable; I've tried several UPnP device listing applications both on Windows PCs and Android devices. Often, devices are not discovered until I look up their IP address via my router's web interface and send them a ping packet, after which I seem to be able to discover them reliably. I'm connecting wirelessly to a Thomson TG585 v8 router; the device I'm currently trying to discover is a Samsung TV that is connected to the router via a wired connection. I've also previously had trouble on the same network with mDNS services (see this unanswered StackOverflow question I asked while I was trying to get that to work) which may or may not be related.

I've tried discovery with Cling Workbench under Windows, and with several different DLNA media server / control point applications under Android.

Any suggestions what may be causing this, or how best to improve the reliability?

0

There is apparently a bug in the TG585 series' handling of IGMP that manifests itself as upnp not working between devices on the ethernet side of its bridge and the wireless side.

According to http://npr.me.uk/telnet.html the following commands issued over the device's telnet admin interface should fix the issue:

eth bridge igmpsnooping config

Use this to view present state.  If state=enabled then apply the fix:

eth bridge igmpsnooping config brname=bridge state=disabled
saveall 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.