1

I'm using privoxy on a debian server and want to disable the privoxy filter deanimate-gifs.

I found these instructions to disable it via the web-based toggle feature:

  • Point web browser to http://config.privoxy.org/
  • Click on View & change the current configuration
  • Click on .\default.action Edit
  • Find line that says Edit, Set to Cautious, Set to Medium, Set to Advanced & Click on Edit
  • Search for deanimate-gifs
  • Click on "Disable" radio button
  • Locate and click on Submit

To use the web-based toggle feature one must have compiled Privoxy with support for this feature, which I have not.

So I just want to change this setting in a configuration file.

What file do I have to edit and what excatly do I have to change?

1

If found the answer:

The filters are set in the .action files. To disable the deanimate-gifs filter I searched for it in the match-all.action and the default.action and commented out the regarding lines.

For more information about the action files: http://www.privoxy.org/user-manual/actions-file.html

Example for the match-all.action:

#############################################################################
# Id: match-all.action,v
#
# This file contains the actions that are applied to all requests and
# may be overruled later on by other actions files. Less experienced
# users should only edit this file through the actions file editor.
#
#############################################################################
{ \
+change-x-forwarded-for{block} \
# +deanimate-gifs{last} \
+filter{refresh-tags} \
+filter{img-reorder} \
+filter{banners-by-size} \
+filter{webbugs} \
+filter{jumping-windows} \
+filter{ie-exploits} \
+hide-from-header{block} \
+hide-referrer{conditional-block} \
+session-cookies-only \
+set-image-blocker{pattern} \
}
/ # Match all URLs

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.