1

I was attempting to backup my system with Time Machine and for whatever reason a passerby disrupted the hard drive wire and the backup failed due to an 'improper ejection'. Now, after attempting to plug the thing back in my hard drive no longer shows up on my desktop (as is the usual) and it isn't listed in diskutil list on the terminal. However, when I open up Disk Utility it is listed, but it won't eject. Disk Utility is telling me something is using it, not sure what though. This is what I've tried to do so far....

  1. Eject with Disk Utility Failed

  2. Turn off computer, unplug and turn back on Failed

  3. From terminal: killall Finder Failed

  4. From terminal: killall Dock Failed (though, I was sure this wouldn't do anything in the first place)

  5. Control-option (click) Finder icon in dock (chose Relaunch) Failed

  6. From terminal ls -l \Volumes Failed (Drive not present)

I'm lost now. If I've lost the files that were on it...fine. It sucks, but whatever. I'm just trying to figure out why I can't unmount it.

1

Try

  umount -fv your_mount_point

The option -f forces the unmount, the option -v enables verbose mode for further diagnosis, if need be. If this fails, the disk is probably damaged.

  • Is there some standard mount point (like sda1 in Linux) for macs? I can't locate the drive in my terminal. I tried diskutil list and it wasn't present. I also tried ls -l \Volumes and it was also missing. I assume the drive is corrupted but what's up with it being in the Disk Utility GUI? Also, I booted up a Linux Virtual Machine (trying this step out of desperation) and it too, saw the drive. – Matt Dec 28 '13 at 17:18
  • @Matt you should be able to see where it is mounted with df -h. If it does not show up, it is not mounted. – MariusMatutiae Dec 28 '13 at 17:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.