I am using latest version of VirtualBox (VirtualBox 4.3.6 for Windows hosts) and after installing any OS and clicking inside of it mouse disappear. It is not visible until I press right CRTL. Anyone know what can cause this problem. I have also installed extension pack.

  • I have had this problem on and off. It seems to be more frequent with 3D acceleration enabled, however. This is different than the "guest additions" problem/solution others have mentioned. Commented Jun 12, 2014 at 19:25

13 Answers 13


In my case, it worked by changing pointing device from 'PS/2 Mouse' to 'USB Tablet'.

While guest is not running, in VirtualBox
-> select the virtual-guest instance
-> click 'Settings'
-> select 'System' in left panel
-> go to 'Motherboard' tab and in pointing device, choose 'USB Tablet' instead of 'PS/2 Mouse'

  • This worked for me. Commented Feb 4, 2019 at 10:17
  • That did a trick for me: CentOS 7.3 inside VBox 6.0.4 Commented Feb 20, 2019 at 7:01
  • Worked for me with CentOS7.6.10.10 inside VBox 6.0.4.
    – dolphus333
    Commented Mar 17, 2019 at 12:37
  • Fix only worked for awhile. When I switched back to host for awhile, the same issue (mouse not clicking) resurfaced in the guest. Changing guest to full-screen fixed the problem again after that.
    – dolphus333
    Commented Mar 17, 2019 at 12:51
  • Worked for me as well
    – Bogaso
    Commented Jan 27, 2020 at 21:49


Machine -> Disabling Mouse Integration


Machine -> Disabling Mouse Integration 

(yes twice, once to turn it off, once to turn it on again) actually fixed it for me.

  • Even just disabling it with (right ctrl)+I and then clicking in the guest window and accepting the "enable again?" dialog is sufficient.
    – tripleee
    Commented Apr 13, 2015 at 14:02
  • The solution in the post just worked for me too (with Ubuntu 16.04 as guest). This might relate to virtualbox.org/ticket/7945. Commented May 9, 2016 at 12:17
  • 24
    this fix doesn't work for me Commented Jun 14, 2016 at 12:27
  • Still working after 5+ years...
    – Gruber
    Commented Aug 8, 2020 at 13:21

Following steps worked for me.

  1. Go to machine settings -> System -> Motherboard.
  2. Select PS/2 mouse as a pointing device.
  • 1
    It worked out of the box
    – Tomasz
    Commented Jun 29, 2017 at 11:24
  • Works so far. Note: machine settings means the Virtualbox settings, not the settings inside the Guest.
    – beat
    Commented Feb 22, 2018 at 17:01

It's not a problem in Virtualbox. RCTRL is set the default button for mouse capturing inside virtualbox. So you would only be able to use the mouse inside VB after enabling mouse capture. If you don't enable mouse capturing you can use your mouse but it will be invisible as the mouse is being used by the Current windows. You can change the RCTRL button by going into File -> preferences and then you can enable mouse capture with other button. Also check when you enable Mouse Capture the mouse will disappear from current windows and show in host windows.


I have the same (or at least very similar problem) with a linux host (debian 8) and a linux guest (debian 7) with 3D enabled. Sometimes the mouse pointer becomes invisible at the guest.

I have the guest additions installed and mouse integration enabled.

For me the trick that solved it was to remove the module psmouse and re-insert it (inside the guest).

sudo rmmod psmouse
sudo modprobe psmouse
  • I believe this is the correct answer! I have Ubuntu 16.04 on OSX High Sierra with VB 5.2.6. Still this issue bothers me every now and then. Tnx buddy.
    – CppChase
    Commented Mar 2, 2018 at 9:14
  • Remove the module inside the host or inside the guess? :O!!!! Commented May 25, 2018 at 10:15
  • 1
    Inside the guest :) Commented May 25, 2018 at 13:47

just unplug the mouse from your pc and reconnect it. I do this whenever I face this issue(I have guest additions installed but still has the problem).

  • 3
    that's good for you, but some of us have trackpads that can't be disconnected, physically or otherwise
    – MarcusJ
    Commented Feb 4, 2015 at 19:54
  • Can't believe that worked haha
    – trueinViso
    Commented Jun 2, 2015 at 18:47
  • I have a logitech performance mx wireless mouse that sometimes disappears in virtualbox when I run some application. when I unplug the usb wireless connector and reconnect it, I am able to see the mouse pointer again. thank you!
    – kimbaudi
    Commented Sep 2, 2018 at 11:19

One stupid thing no one mentioned, the actual key combo to release your cursor is SHIFT+right ctrl, not right-ctrl. It doesn't say that anywhere in the interface, docs or website. I'm not sure this is your problem, but others might run into this.

  • Or on Mac, the right-side command button ⌘.
    – Mike
    Commented Dec 1, 2016 at 17:42

This happened to me too when I disabled mouse capture. The mouse cursor outside of VirtualBox became stuck in one place (because I disabled it) and the new mouse pointer in VirtualBox becomes invisible.

The best thing to fix this problem is to actually use an external device, such as a PC contoller with analog sticks. So, plug in your PC controller of whatever external device you want first, then download a free program called JoyToKey or something similar. I would suggest JoyToKey, it works perfectly.

Now, open JoyToKey and map your keyboard keys, like w,a,s,d or up, down, left, right and left and right mouse clicks, including middle mouse roll, and mouse movement axis (what you use to move a mouse, I mapped mine on my controller analog sticks to move pointer around) onto your PC controller.

Next, open VirtualBox (disable capture). This way, at least now you can move the pointer that was stuck initially in one place with your pc controller.

So, if you want to use in Unity3d, open Unity3d now. Move your pointer using your external device, try to preview a game you made, and now you can look around using the mouse! Alternatively, disable hardware acceleration (drag slider to none instead of full) in Display options when inside VirtualBox, (however this doesn't work if you want to use Unity3d, because the pointer still disappears when hovering over program)


The solution for me is to setup the "Mouse Integration" shortcut in File->Preferences->Input->Virtual Machine Tab and press the shortcut twice to toggle the Mouse Integration by working keyboard.


If you don't want to keep pressing Ctrl to release the mouse cursor every time, simply install the VirtualBox Guest Additions by clicking on Devices > Install Guest Additions.

Virtual machine, mouse cursor only works within the box

  • I am not sure I made myself clear but when mouse enters VB it is not visible and I cant move it ( I dont see it ). Commented Dec 29, 2013 at 14:19
  • Did you install the "guest additions" and then try again?
    – cowgill
    Commented Dec 30, 2013 at 1:48
  • 3
    For me, this happens with Guest additions installed. Commented May 9, 2016 at 13:11
  • I get it with guest additions too. I solve it by randomly doing stuff like rebooting the vm, reinstalling guest additions etc. It's very annoying when there's probably a single bit in the wrong state somewhere.
    – user115145
    Commented Oct 21, 2016 at 17:23
  • I third that, it happens to me with the correct version of Guest additions installed Commented Aug 27, 2018 at 22:31

One possibility is that the screen is failing to refresh, which can make it seem like the mouse pointer has disappeared. This can be fixed by resizing the window temporarily which forces the screen resolution to change.

Please note: The question states that the mouse can be recovered by pressing right-CTRL. The mouse pointer is only disappearing in the guest, not the host.

  • 1
    and how do you resize the window without a mouse? Commented Aug 27, 2018 at 22:29
  • @GeorgeM Resize the VM window from the host. The problem describes the mouse disappearing in the VM only. If the mouse has disappeared entirely from the host, then you have a different (bigger!) problem.
    – RoG
    Commented Aug 29, 2018 at 15:41
  • i was thinking the same exact thing @GeorgeM. I would use the mouse to resize the VM window from the host, but how can I do that if I can't see the mouse and I can't access the mouse pointer outside of the vm? sree's comment helped with my situation.
    – kimbaudi
    Commented Sep 2, 2018 at 11:21
  • @kimbaudi The original question explicitly states that the mouse can be released by the guest for use on the host by pressing the righthand CTRL key. If this is not working for you then you have a problem with the mouse/keyboard being released back to the host, which is a different issue.
    – RoG
    Commented Sep 3, 2018 at 13:32
  • @RoG The original title simply stated "Mouse disappears in Virtualbox" and I didn't read the question carefully to notice that user can move the mouse outside the guest vm window. Sorry for the downvote, but I'm unable to undo it. Hopefully, other's can understand my issue is different than the OPs. Anyways, my problem was solved by Sree's answer.
    – kimbaudi
    Commented Sep 3, 2018 at 21:52

Well for me, the problem was solved by selecting my external mouse under USB in the devices menu. Maybe it installed the driver or something. (Sorry if I sound like a noob, but these are my 1st 30 mins into virtualbox.)


i was encountering the same problem. previously it was working perfectly. i solved it by just resetting it. Machine-> Reset try this and inform me if it helped you.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .