1

I'm currently playing with hostapd. My current network configuration (well the relevant bit anyway) is a Asus RT N56U as a primary router (its at 192.168.1.1 on ipv4), and a ubuntu 12.04 server x86 system running hostapd as a access point (its 192.168.1.127). The primary router does ipv6 as well, and does this via ipv6 rd.

The ethernet port and wireless adaptor on the ubuntu server are bridged, and hostapd works. Its a very similar setup to this. The only dhcp server is on the main router, and the hostapd system does not have any flavour of dhcp, dnsmasq or any of the other things you'd have in a 'proper' ghetto router.

This gets a little strange since the system is, as far as I can tell not actually set up to use ipv6 - I commented out the line since I was going to enable it later.

Unlike my last question, where systems were not getting ip addresses, both my hostapd access point and any clients connected to it are getting ipv6 addresses. Despite the hostapd access point not actually being configured for ipv6. What's happening? How do I turn off ipv6, if I chose to?

This is the /etc/network/interfaces file - I'm pretty sure this is where I think the answer should be, but it looks pretty textbook.

auto lo br0
iface lo inet loopback

# wireless wlan0
allow-hotplug wlan0
iface wlan0 inet manual

# eth0 connected to the ISP router
allow-hotplug eth0
iface eth0 inet manual
#iface eth0 inet6 auto
# Setup bridge
iface br0 inet static
    bridge_ports wlan0 eth0
    address 192.168.1.127
    netmask 255.255.255.0
    network 192.168.1.0
    ## main router ip, 192.168.1.1 also runs DHCPD ##
    gateway 192.168.1.1
    dns-nameservers 192.168.1.1
  • 1
    What IPv6 address is it getting. – Brian Dec 28 '13 at 15:52
  • @Brian: An address in the 2404: range that I usually get off my router. I didn't confuse it with a FE80: link local address. – Journeyman Geek Dec 29 '13 at 3:11
0

Turns out it was pebkac. I rebooted the system to find that there's no ipv6 address. I un-commented the line, and ran ifup eth0 and got

ssh stop/waiting
ssh start/running, process 7220
net.ipv6.conf.eth0.accept_ra = 1
net.ipv6.conf.eth0.autoconf = 1
ssh stop/waiting
ssh start/running, process 7268

Clearly I did have ipv6 explicitly set up, only I derped and didn't realise it was.

In the end the solution was turning it off and on again, which I clearly forgot to do.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.