Host OS: Windows 7 x64 (up2date)

Guest OS: Linux Mint xfce LTS (maya) (x64)

Vmware Workstation 9.0.3

VMware Tools is installed and seems to work.

Problem description:

When my mouse pointer moves in or out of the guest screen (in full screen too with vmware panel at the top) the mouse pointer stops for a sec at the border. Afterwards I can move the pointer further and it's automatically grabbed/ungrabbed. This is happening every time I enter/leave guest screen.

In my Xubuntu guest VM I can move the mouse pointer in and outside the screen without a delay. How can I have the same behavior in my Linux Mint guest system?

P.S.: I'm using a Synaptic touchpad.

  • Does this delay happen if you uninstall VMware Tools?
    – harrymc
    Dec 31 '13 at 16:18
  • It's the same behavior, if vmware tools are not installed. So my guess is, that they are not correctly installed? I get the same behavior on a fresh Xubuntu installation, but my old one is still working fine.
    – keiki
    Jan 1 '14 at 15:31
  • If this happens on a fresh install, logic says that VMware Tools are not to blame. I would wildly guess that in your "old one still working fine" you have maybe installed a version of VMware Tools that avoids the problem, but that newer versions don't.
    – harrymc
    Jan 1 '14 at 17:51
  • I copied the install directory vmware tools of my running vm to my new vm and tried to install it again. But still not working
    – keiki
    Jan 1 '14 at 19:08
  • Then it has probably something to do with newer Linux versions, but no idea what, maybe a driver.
    – harrymc
    Jan 4 '14 at 13:44

The reason is, that every time I change focus numlock is changed too.


The touchpad software of Dell (I guess it's synaptic) has a so called TouchGuard feature(I think its enabled by default), which prevents using the touchpad mousepointer while typing on the keyboard. It seems, that vmware is calling the numlock key every time I switch. So every time TouchGuard thinks "oh he is typing, mouse has to stop".

My other old VM works, because numlock simply doesn't have to change.


  • Either change the numlock so that guest and host have both numlock on or off.
  • Or disable TouchGuard in your touchpad software configuration.

Update: Capslock key may obviously also have the same issue.

  • I had the same issue and toggling numlock within my guest Ubuntu system did the trick. Thanks for getting to the bottom of this, since I would not have thought of it. Feb 14 '14 at 21:54
  • Well, I faced the same issue, after researching a lot came across this and solved my problem, Couldn't even tell what was the problem before, thanks.
    – Indigo
    Apr 25 '14 at 22:17
  • Never would have suspected numlock. Thanks for the fix. Mar 2 '18 at 19:51

This is almost certainly a pointer integration issue. Have you seen this guide? http://youtu.be/07vA52Oxzos

  • I installed it already this way and most other VMware tools feature are working as expected
    – keiki
    Jan 5 '14 at 20:52

I solved the problem. Just go to unity mode once, and exit it. then after mouse will not stick during changing focus in borders of VM. have fun...

  • To be honest what I did will make Numlock and capslock of VM and main OS the same and this solves the problem. :) regards
    – siavash
    Sep 3 '15 at 12:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.