21

Since upgrading to Windows 8.1 from 8, I've noticed that doing a search (Windows + S) is not turning up any Control Panel settings. For example, if I try to find Windows Update by typing in "update", I'm not getting any results. It's almost if the Settings option of the search is not actually doing anything.

Example search with no results

Doing the same search from within the Control Panel itself gives me the results I'm looking for:

enter image description here

Any insight as to why this is happening? I'm fairly certain this worked fine in Windows 8, but I have no way of verifying that. Is this just a setting somewhere that I've missed?

5 Answers 5

6

We had been experiencing exactly the issue you described.

Recently we had migrated to using SSDs and as part of that, we disabled the "Allow files on this drive to have contents indexed in addition to file properties" setting on the C drive.

Allow files on this drive to have contents indexed in addition to file properties

After re-enabling this setting, we found that the Control Panel settings returned in the search results (in both Everywhere and in Settings).

5
  • Looks like you're right. This is disabled for my SSD as well, which is where Windows lives. I'd rather not use the search than unnecessarily degrade my drive; I'll have to find a workaround instead. Thanks for the help!
    – Ryan
    Jan 8, 2014 at 15:41
  • 2
    Using the Indexing Options applet in Control Panel, you can disable most/all indexing, but just keep the Start Menu indexed (which I believe provides the Control Panel search results).
    – lxalln
    Jan 8, 2014 at 16:54
  • I went back through and tweaked my indexed locations and enabled the setting you mention above. I also moved the index location onto a different HDD to, hopefully, spare my SSD the excessive write ops. Everything seems to be humming smoothly now. Thanks again.
    – Ryan
    Jan 8, 2014 at 21:53
  • My Acer Iconia W700 is SSD. The indexing is disabled somehow (dont remember doing it). After I enabled it the search is working again!
    – Rosdi
    Apr 11, 2014 at 7:20
  • 1
    @Ryan: you can just enable this option at folder level. In my case, I enabled the option on C:\ProgramData (where windows 8 keeps start menu). Then go to index options, click "Modify" and verify the start menu and all child folders under it can be indexed.
    – Codism
    Nov 20, 2014 at 17:15
10

I had this exact same problem. However the solution wasn't to enable indexing on my SSD.

Counterintuitively, I solved it by simply disabling the Windows Search Service.

Windows Search service disabled

As soon as I disabled Windows Search, search worked perfectly again.

My PC is new and I had recently enabled Windows Search when Microsoft OneNote prompted me to.

OneNote prompts to enable Windows Search service

Given the choice, I went with slower OneNote searches and a working Search charm!

1
  • 2
    This worked when I was using Windows 8 and I hoped it would work on Windows 10, but when I disabled it on Windows 10, not only does this not fix the problem, but it severely reduced the quality of the search. Aug 27, 2015 at 16:49
1

Hey to do a search in the settings menu the default keyboard shortcut is "Windows + W" not "Windows + S". So try searching for update in the settings menu. Also if your'e not getting anything from typing update then you can try to search for windows update. It should bring up the settings for the update options.

4
  • 5
    Win+W will still search through the results applicable to Settings, so it will not make any difference except for the limitation of other hits.
    – Thor
    Dec 29, 2013 at 18:41
  • Does your other control panel settings appear in there?
    – user285409
    Dec 29, 2013 at 18:42
  • Yup. The only difference I can see is that "Settings" returns a higher number of results without narrowing your search terms.
    – Thor
    Dec 29, 2013 at 18:44
  • 5
    Using Win+W makes no difference. No Control Panel settings appear in the search at all. Wording makes no difference, either; nothing from Control Panel shows up.
    – Ryan
    Dec 29, 2013 at 18:59
1

I also removed indexing from the drive, and lost all control panel and settings in searches.

You can get them back by enabling Allow files in this folder to have contents indexed in addition to file properties for the folder (and all folders and files under):

C:\Users\{user}\AppData\Local\Packages\windows.immersivecontrolpanel_cw5n1h2txyewy\LocalState

That way you can keep indexing off for most of your drive.

(I've tested this on Window 10, not 8.1)

Source: Windows 10 forum

0

In my case, I had to:

  1. Enable "Show Administrative Tools" in "Tiles" settings (see this answer)
  2. Add missing links such as "Windows Update" and "Programs and Features" manually in %AppData%\Microsoft\Windows\Start Menu\Programs\Administrative Tools` (not sure why they were not there in the first place).

I can now type Win + S and type "Update", and "Windows Update" shows up.

If you have trouble creating these shortcuts, here are a few links that might help: How to create a Programs and Features shortcut and How to create a Windows Update shortcut

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.