1

I have previously set up RDP to work on port 3456 at my last home. Now in a new location, the only thing that has changed is the network environment (e.g. router, ISP). The computer configuration is unchanged.

Originally, I had it working with this configuration:

  • RDP service configured to listen on port 3456
  • Windows 7 Firewall rule created to permit inbound access to port 3456
  • Static IP address assigned to host machine
  • Port forwarding rule created to forward traffic on port 3456 to host machine

And it worked.


New ISP: Comcast Xfinity

New cable modem/wireless router: Arris TG862

I have accessed the router at 10.0.0.1 and added the port forwarding rule. Using the WAN IP address, I can confirm that the port is open via telnet from a remote machine. If I disable the forwarding rule, telnet is unable to connect. So I enable the rule and it works as expected.


Troubleshooting

I have not altered the (previously working) Windows 7 host configuration. I have verified that it is still configured to listen on the same port and that the firewall rule is enabled.

I can connect via RDP using the static LAN IP address 10.0.0.4 and port 3456. I can connect to the WAN IP address using the open port 3456 via telnet. I cannot connect to this same WAN IP address and port via Windows Remote Desktop Connection.

Edit: I have also tried disabling Windows Firewall entirely, and placing the host in DMZ on router config.

How should I troubleshoot further?

1

Disable Windows Firewall entirely to rule it out. It's possible windows firewall is letting in LAN ip's... but nothing external.

You troubleshot the port is open on the external router... but did you verify that the rule is indeed forwarding to the proper port and internal IP? (sorry if that sounds too easy... but sometimes... it is!)

1
  • I did try disabling the firewall entirely; no dice. I also placed the LAN IP in DMZ on the router and also no dice. I have verified that it is reaching the correct host and port thusly: With rule allowing inbound port 3456, I get the telnet prompt successfully. If I disable this rule (e.g. enable firewall), the remote client CANNOT telnet to port 3456. So I do not think networking is an issue, since it does indeed appear to be reaching the host computer (at least via telnet). I just only get the RDP session to work on LAN and not via remote WAN client. – pztrick Dec 30 '13 at 2:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.