1

I have WampServer installed, and I installed Microsoft SEO Toolkit, I guess that has the IIS dependency. And I guess the iis service uses port 80.

Now every time I start WampServer, I need to go to cmd and type iisreset /stop, or else WampServer will not get online. I'm tired of this.

How can I remove iis or whatever to "open up" my port:80 ?

Thanks for any help !

P.S.

I'm not sure what's relevant. Please tell me if I need to post a list of my installed programs or anything.

5 Answers 5

1

I always redirect WAMP to other port So left click on Wamp in the tray icon, and select Apache > httpd.conf then find the line:

Listen 80

Change it to:

Listen 8080
5
1

You could also remove the binding on your IIS website so it points to port 8080, and leave your WAMP server on port 80.

  1. 1.Open Internet Information Services (IIS) Manager.
  2. Select the Web site that you wish to configure.
  3. In the Action pane, click Bindings.
  4. Click Add to add a new site binding, or click Edit to change an existing binding.
  5. Click OK to apply the changes.

You'll want to edit the existing binding, and simply change the port number to a different one. If you aren't using the website at all, you can right-click on it and disable it as well. This will stop it from grabbing port 80 after a reboot.

1
  1. Open The Control Panel
  2. Unistall or Change a program (from programs and features)
  3. Turn windows features on or off (left side to panel) click this
  4. you can see "Internet Information Services" (you can uncheck)

enter image description here

5.Than restart all services from Wamp server

0

press ctrl+f and search for "Listen 80", change this line to "Listen 8080" (u can change this port as what you want), and then close and save the httpd.conf file. Open a web browser and enter "[];, this will open the WampServer configuration page where you can configure Apache, MySQL, and PHP.

1
  • Welcome to Super User! This duplicates another answer and adds no new content. Please don't post an answer unless you actually have something new to contribute.
    – DavidPostill
    Oct 10, 2015 at 12:05
0

Go to the WampServer icon in the system tray and right-click > Exit, then Open WampServer again, and it should now turn green. Now go to localhost:8080 to see your server config page. This happens to me once: I uninstalled the IIS, and the port 80 still was used.

Not the answer you're looking for? Browse other questions tagged or ask your own question.