I am attempting to host a development website from my laptop using WAMPServer. My goal is to install WordPress and have users log in from their homes.

  • I’ve successfully installed WAMPServer 2.2
  • I’ve included localhost in my hosts file
  • I’ve removed the # from the front of Include conf/extra/httpd-vhosts.conf

Now localhost works perfectly until I edit my httpd-vhost.conf file to include the following:

<VirtualHost *:80>
    SeverAdmin webmaster@localhost
    ServerName localhost
    DocumentRoot "C:/Program Files/WampServer2/www"
    ErrorLog "C:/Program Files/WampServer2/www/logs/error.log"
    CustomLog "C:/Program Files/WampServer2/www/logs/access.log" common

Once I restart WAMPServer, the icon stays orange. If I attempt to put WAMPServer online, I get an alert titled Aestan Tray Menu stating Could not execute menu item (internal error). [Exception] Could not preform service action: the service has not been started.

(Port 80 tested as "not actually used".)

When I run httpd.exe, a command-prompt opens then immediately closes before I can read it. I’ve tried various formats to <VirtualHost *:80> with no avail, however once I comment out my changes, I am able to successfully restart WAMPServer and access localhost.

I haven’t been able to find any posts about this problem anywhere.

[EDIT]: My error logs are not including any new entries when attempting to restart WAMPServer with <VirtualHost *:80> included, however when commented out, WAMPServer starts & stops without error and the following lines are added:

Child 10084: Child process is running
Child 10084: Acquired the start mutex.
Child 10084: Starting 64 worker threads.
Child 10084: Starting thread to listen on port 80.
Child 10084: Starting thread to listen on port 80.
Parent: Received shutdown signal -- Shutting down the server.
Child 10084: Exit event signaled.
Child process is ending.
Child 10084: Released the start mutex
Child 10084: All worker threads have exited.
Child 10084: Child process is exiting Parent:
Child process exited successfully.

There is also a line before these that says [warn] NameVirtualHost *:80 has no VirtualHosts.

I’ve been trying to get this to work for days. Any ideas what’s wrong and how to fix it?

1 Answer 1


I had some similar issues but manage to Print Screen my httpd.exe command-prompt before it closes. I figured out the error that was in following entry in my httpd-vhost.conf file.

NameVirtualHost *:80

nameVirtualHost is deprecated, it's neccessary to use just Listen

My own corrected httpd-vhosts.conf

My own WRONG httpd-vhosts.conf

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .