1

I have just configured a Ubuntu server at home, which I have named CRICHTON, running Samba 3.6.3, and created a test share, named Media. Sadly, I can't connect to it from my Windows 7 SP1 machine. I have changed the LAN Manager authentication level to "Send LM & NTLM - use NTLMv2 session security if negotiated" which seems to have helped a lot of people, but to no avail.

I'm on a home network, and I can cheerfully ssh into my server. I can even see the server and shared folder in an Explorer window. I've managed to achieve some success by creating a workgroup, joining it and identifying it in the samba config file, but then only read-only access seems available, and anyway WITHOUT authentication of some kind it's not much use. Right now, without workgroup shenanigans, as soon as I try to open a share I am asked for a login. Particularly, I am asked:

Enter Network Password

Enter your password to connect to: CRICHTON

I enter my user name and password, which is the same as my Samba user name and password. Then the login repeats itself, only this time it prepends my username with the name of my machine, only allowing me to submit a password.

Unfortunately my Windows Networking knowledge is poor. Does anyone have any clues? Is there a step-by-step guide to connecting to Samba from Windows 7 out there somewhere? I've found one that ignores security issues, but that isn't appropriate here.

  • In /etc/smb.conf There is a line "Security = " what is after the equal sign? What kind of password database is it set to? tdbsam,passwd, or other? Try using the samba add user command to see if that helps. smbpasswd -a username After setting a password try again. – cybernard Dec 30 '13 at 17:45
  • Whoops the location could also be /etc/samba/smb.conf – cybernard Dec 30 '13 at 17:56
  • security = user passdb backend = tdbsam Several users already added, none working :-( Thanks for your help! – Guy Davidson Dec 30 '13 at 17:57
  • In smb.conf find [Media] Is one of the entries read only = No ** another good entry is **Browseable = yes additionally: write list = <list of usernames here> – cybernard Dec 30 '13 at 18:03
  • Additionally you need to restart the nmb and smb samba services after making changes to smb.conf – cybernard Dec 30 '13 at 18:03
0

Cybernard was able to walk me through this. There were several things wrong, but particularly the share directory was created with unhelpful permissions, the user I was connecting as wasn't a member of the appropriate group, and I hadn't created a write list for the share.

Clearly there is a lot of brittleness between Samba, Linux and Windows 7.

  • please write out how to make it work as a single post so the comments can be deleted – endolith Sep 27 '16 at 0:40
  • Sorry endolith, this was three years ago and I don't have records of the conversation. It took several hours, I can tell you that, and several iterations of conversations. The comments above were only scratching the surface: the discussion in chat was where the revelations were. – Guy Davidson Sep 27 '16 at 14:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.