MY laptop (2013 Razer Blade) has three USB 3.0 ports, no USB 2.0 ports. I have a variety of USB 2.0 devices, all of them have worked up until last night. For whatever reason one of the ports no longer recognizes any of them, no power, nothing. The other two work normally.

At first it would seem my port is dead, but I tried a number of devices and found something weird. My USB 2.0 flash drives, keyboard, and mouse are no good - but my USB 3.0 flash drive works. So obviously the port is not dead, since it recognizes the device and I can use it just fine, so why isn't it working with the USB 2.0 devices?

Unfortunately I don't have any other USB 3.0 devices to try.

Further info:

  • System is Windows 8 x64
  • Nothing at all shows up in device manager for the USB 2.0 devices
  • The other two ports function with any device flawlessly.
  • The USB 3.0 device will not work if connected via the USB 2.0 pass through on my keyboard. Though it's blue LED comes on, it still isn't recognized by the computer. (pass through works fine if connected to another port)
  • This is the front most USB on the left side.

That sounds like physical damage to the port. The USB 3.0 pins are intact but one of the USB 2.0 data pins is likely damaged.

  • USB 3.0 negotiation takes place using the USB 2 data pins, no? – Ben Voigt Aug 11 '14 at 19:49

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.