0

I think I shot myself in the foot here, but let me quickly divulge what's happened:

  1. Intel Matrix Storage Manager started reporting that one of the two disks I had in a RAID1 array configuration had failed. I knew it was going to fail and had started backing things up beforehand (but not everything).
  2. Knowing that I couldn't care less about the mirroring (decommissioning this machine altogether), I rebooted into the Intel Matrix RAID manager and reset the one good disk into a Non-RAID configuration and pulled the failed disk out of the machine.
  3. After the reboot, I'm missing a second partition I used to have (my D: drive). I had two 640GB disks in the array; partitioned into two drives: 100GB for C: (OS) and the rest for D: (Data). Everything of importance was on that D: drive.

Is there any way to get it back? I've tried various partition recovery tools and whatnot but they are confusing and scanning didn't find anything. I assume I destroyed a partition table or altered the MBR in some way by resetting the one good drive to Non-RAID configuration. I just need to recover the files, finish sending them off to my NAS and then I'm going to reformat the remaining good disk.

Does anyone have any good next steps or pointers to get that missing partition back? Windows reports it as unallocated space. I have not formatted or altered the drive in any other way.

0

If your data is important, I would invest in a program such as GetDataBack ($79, http://www.runtime.org/data-recovery-products.htm ) which will scan the drive and recover the data, or take it to a professional who will usually do it for a similar price ($60-$80).

The more you try to fix it, the more likely you are to mess it up. Recover the data, then you are free to re-format the drive afterwards.

|improve this answer|||||
0

It turns out that this logical partition (D:) was simply marked as deleted. I was able to use EaseUS Partition Master Free Edition to discover and "undelete" said partition.

Note: I'm in no way affiliated with this software tool -- it was the 6th or 7th one I had tried and was the only one that worked for me. Hopefully it can be useful to anyone else stumbling upon this post.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.