I have just received a new laptop, (HP Elitebook 8770w) and I am encountering an odd issue. Icons for a couple of programs are not displaying correctly. The programs currently affected are TeamViewer 9 and Google Chrome.

I have a shortcut to Google Chrome pinned to my taskbar, and TeamViewer is visible as a recent program in my Start Menu. For both of these applications, the respective shortcuts and actually .exe files are showing the Windows generic icon (piece of paper, corner folded, windowed exe in the icon), but the programs work just fine.

I have tried the following:

Manually resetting the icon, by right-clicking and going to properties. When I look at the shortcut properties for Google Chrome, the properties window shows the correct icon. I notice that when I click "Change Icon" I get a message saying "Windows can't find file %ProgramFiles%\Google\Chrome\Application\Chrome.exe", which I assume is because I don't have a 64bit version of Chrome, so it's actually in Program Files (x86). I am curious as to why the error is bringing up this path. When I manually browse to the chrome.exe, I can pick the correct icon. However selecting it does nothing.

Deleting the thumbnail cache by running cleanmgr.exe and making sure I am cleaning up thumbnails. After rebooting, the issue was still present.

I have manually deleted the thumbnail cache file (%LocalAppData%\IconCache.db). After rebooting, the issue was still present.

I have changed my color depth to 16bit and then back to 32bit to see if this would clear a thumbnail cache. When I am running in 16bit, the icons actually display correctly, but disappear again when I go back to 32bit.

Also (and this is a bit long winded, so bear with me), if I open Chrome, right click on the icon and unpin it from my taskbar then the icon goes back to normal. While Chrome is open if I right click on the icon, it turns generic.

Can anyone offer any other suggestions to try and fix this? Reinstalls of the programs have not made any change. (I have tried to post images with this question, but I do not have sufficient reputation points to do so).

As for security software, I am running Microsoft Security Essentials, and HP ProtectTools (but only the credential manager is running, I am not using the privacy blocker or device administrator user stuff). Disabling these tools has also made no difference.

  • I've seen this plenty, it's annoying. ;) Sometimes it's the order of doing things that matters. Try clearing the Icon cache, reboot (if need be, depending on how you cleared it), then change the exe's icon to something else, apply it, then back to what it should be, apply again. Did it stick? Dec 31, 2013 at 15:43
  • 1
    Your resolution to your problem is an answer to your question. You really should post that as an answer.
    – Ramhound
    Dec 31, 2013 at 16:36

5 Answers 5

  1. Right click on the Chrome icon
  2. Click change icon
  3. After that it will pop up this error %ProgramFiles%\Google\Chrome\Application\Chrome.exe after the error it will still bring up icons
  4. Change look for icons in this file to %ProgramFiles% (x86)\Google\Chrome\Application\chrome.exe
  5. Click ok select the Google icon you want and you're done.
  • This doesn't work
    – yoavram
    Nov 3, 2014 at 6:58

It appears that the issue was connected (somehow) to the fact that my display was set to show text at 125% of the size. I had noticed that my spacing in the Outlook 2010 navigation pane was too big, and found the fix was to change the text size for my display. After logging out and back in (required for the text size change to take effect) all my icons are showing correctly in shortcuts and in their respective directories. I have no idea why this is causing the issue, but changing the font size back to 125% does indeed recreate the issue. Hopefully this will help someone else in the future.


I had the same problem, all I had to do was unpin from the task bar and re-pin to the task bar and the icon was back.


The answer is easy. Open Ie and make it your default browser. Close Ie.

Open Chrome and make your default browser.

All Icons are back.


Try if this order of actions works for you:

Reset your screen to 16bits colors Delete the iconcache.db file Reset your screen to 32 bits colors

Did the trick for me...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .