18

Some days ago I rebooted my windows 8.1 system. After the reboot all my system texts were very cryptic - showing only some strange symbols. After some investigation I discovered that my c:\windows\fonts folder was nearly empty. So I copied the font files from another windows 8.1 installation to the nearly empty folder. As soon as I had copied the files the system texts were readable again.

But after another reboot the problem occured again - the systems font folder was empty again. Does anyone know why windows deletes my font files during a restart?

3
  • Can you tell us what your startup program are? They will be shown in Task Manager under the Startup tab.
    – K.A.Monica
    Jan 1, 2014 at 14:23
  • Have been having the same exact problem since just a day ago. K.A., I've removed everything from startup and it didn't help. Jan 2, 2014 at 10:18
  • You can find a list of my autostart processes on the screenshot here Jan 3, 2014 at 14:06

4 Answers 4

21
+50

This has happened to me twice now, both times after a failed font installation. The problem occurs not only after a restart, but also after logging out of and back into a Windows account.

I ended up solving it with a bit of a scattershot approach (mostly out of frustration), but everything seems to be working now after multiple reboots. You'll need a copy of a C:\Windows\Fonts directory from a PC that is not suffering from this problem.

  1. Copy the contents of a C:\Windows\Fonts directory from a PC that is not suffering from this problem and paste them into the afflicted C:\Windows\Fonts directory.
  2. Open up Regedit.
  3. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\
  4. Export (just in case) and then delete the entire Fonts group. I also deleted the groups Font Management, Font Drivers, FontLink, FontMapper, and FontSubstitutes, though I re-added them later and suspect they were unrelated.
  5. AGAIN copy the contents of a C:\Windows\Fonts directory from a PC that is not suffering from this problem and paste them into the afflicted C:\Windows\Fonts directory.
  6. Reboot.
6
  • 3
    I took this approach on a winxp machine a number of years ago. The "fonts folder" is a magic folder in that windows relies on the registry and does not ever present to you what is on the disk in an "honest" fashion. In my case, the first entry in the fonts list in the registry was corrupted. I exported the key, deleted it, then imported the export file. The import process dropped the invalid entry.
    – horatio
    Jan 8, 2014 at 22:33
  • 3
    I can confirm that Font Management, Font Drivers, FontLink, FontMapper, and FontSubstitutes do not need deleted. I followed the steps above and deleted only the Fonts group and it did resolve the issue.
    – teynon
    Feb 12, 2014 at 19:50
  • 2
    FYI: Copying over the fonts was just enough to refresh the UI with a proper look and feel. No reboot or registry modification was required. I have win 8.1.
    – lnaie
    Mar 24, 2014 at 11:17
  • In my case the problem was due to encrypted font files (Windows EFS). To solve it I did the following: 1. Copy C:\Windows\Fonts to another directory 2. Unencrypt all encrypted (green) fonts 3. Paste to C:\Windows\Fonts 4. After restart, all fonts work as they should Sep 15, 2014 at 12:11
  • the fonts can be found here: withsteps.com/2621/…
    – Toskan
    May 2, 2015 at 6:54
2

Had the same issue and the selected answer didn't work, I just kept getting an endless crash of the UI (Explorer.exe) after logging in from a garbled login screen. So here is what worked off the command line.

On a working Mac/PC/Linux machine ...

  1. Download the default Windows 8.1 font pack from this post (direct link). The SHA256 hash of the .zip is

openssl dgst -sha256 Windows8.1-Default-Fonts.zip

SHA256(Windows8.1-Default-Fonts.zip)= d2c0cccc8f77f4d8198161cb452c9758608fdb70d64a9347c0b1d911b5d1af49

  1. Extract the .zip file above to a USB flash drive. Example: to D:\Fonts so you'd have something like D:\Fonts\Arial.ttf and so on.
  2. Download the powershell scripts from this post (direct link)
  3. Extract the .zip file to the same USB flash drive, to say D:\FontScripts\ so you have something like D:\FontScripts\Add-Font.ps1

On the affected computer ...

  1. Boot into Safe Mode with Command Prompt (see details below)
  2. cd c:\Windows\Fonts (enter) and del /f /s /q *.* (enter)
  3. type PowerShell (enter) into the command prompt
  4. type Remove-Item "hklm:\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts" (enter). We remove this because it's corrupt.
  5. Insert the USB flash drive
  6. Type D: (enter) then cd D:\FontScripts (enter)
  7. Type .\Add-Font.ps1 D:\Fonts (enter). You'll get errors about a missing registry settings. Ignore for now.
  8. Reboot. This will rebuild hklm:\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts that we just removed in #4 above
  9. Boot into Safe Mode with Command Prompt (same as step #1)
  10. type PowerShell (enter)
  11. Type D: (enter) then cd D:\FontScripts (enter)
  12. Type .\Add-Font.ps1 D:\Fonts (enter)
  13. Reboot.
  14. Get a beer and don't install corrupt fonts.

Booting Windows 8.1 into safe mode

Detailed as option #2 in this blog post, listed here for completeness.

  1. Reboot the affected computer till you hit the login screen
  2. Click the power icon in the bottom right corner. If your fonts are REALLY messed up, this will just be a square box :(
  3. Press the SHIFT key and click the last menu option (it reads Restart on good systems)
  4. Select Troubleshoot => Advanced options => Startup Settings => Restart
  5. When it restarts, select #6 i.e. Safe Mode with Command Prompt
4
  • Oh man. This worked for me. You saved my life!! THANKS
    – leukosaima
    Oct 28, 2015 at 23:58
  • Side note, I did not have the password to the local admin account, and safe mode + networking was still crashing Explorer non stop. So i followed these steps with my domain account (that has admin privs) but used ctrl-alt-del to launch task manager and run cmd as admin from the file menu. Had to use google on another machine to look at screenshots to make sure i was clicking the right thing through all the gibberish. With PS I killed explorer and was able to type properly without losing focus on the CMD window..... sheeeeesh. Thanks again
    – leukosaima
    Oct 29, 2015 at 0:02
  • I had this happen in Windows 10 after installing bogus font files, I guess. It all worked fine up til 9. After rebooting the boot into safe mode, or any other modes brought up a flickering display that was impossible to read or use. The solution for me was to use remote desktop connection (RDP) to remote into the Windows 10 machine from a different machine and perform the powershell script from the RDP. Nov 2, 2015 at 15:51
  • The same happened to me. Be careful with deleting the Fonts registry key -- I could not get to the Windows login screen anymore after that. And I did not see a way to use PowerShell from the recovery cmd while booting, so had to find a way with the available tools. See superuser.com/q/997430/519111 for elaboration. Nov 8, 2015 at 15:36
1

Aside from being a malware issue, there could be corruption on your hard drive. First, check the SMART values of your disk drive. If it all looks good, then run a chkdsk /f, and then an sfc /scannow.

1
  • It's very unlikely that a SMART problem will delete files always from the same particular folder and without any other disk errors!
    – harrymc
    Jan 8, 2014 at 20:08
0

This is not a "normal" problem - it's just too weird.

The first step should be to do a deep anti-virus scan on the computer. I see that you have Avast, so use it first, then download and use Malwarebytes Anti-Malware.

If no viruses were detected, run sfc /scannow.

If the sfc scan found no errors, to find out if some installed product is responsible for this problem, restore the fonts and reboot in Safe mode. If the files have disappeared again, then this is a Windows problem. Otherwise if the files are still there, then some installed product is causing this.


if the problem is caused by an installed product, first use Avast to do a boot-time scan.

If Avast finds nothing, use Autoruns to turn off startup programs in bunches until you find the one causing this. Each time restore the fonts and reboot again to check.

Once you find the product causing this, restore startup programs using Autoruns.


For the case where Windows destroyed its own font data, you could :

  1. Get the contents of C:\Windows\Fonts from another PC
  2. Copy these fonts into a temporary folder
  3. Use regedit to delete (after saving) the contents of
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts
  4. Reboot
  5. Copy the fonts into C:\Windows\Fonts
  6. Re-install the fonts by opening Control Panel / Fonts
  7. From the File menu select 'Install New Fonts...' and add the fonts from the temporary folder.
1
  • Also shoot for Combofix if you think it's a malware issue. I have found it to be quite effective.. Jan 7, 2014 at 20:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.