Something has happened to the MySQL server installation on my computer. Normally, the MySQL notifier program, which is supposed to start automatically and run in the system tray has stopped starting up automatically, and instead throws these two errors in order of appearance below. When I try so start it on my own, these two errors are thrown again. How can I resolve this issue without losing my data and if possible, my configuration settings as well? I do not care if I have to reinstall MySQL as long as I can at the very least retain my data.

MySQL Error #1

MySQL Error #2

  • Sounds like the first thing you should do is backup the database. After you do that I would try reinstalling the notifier. – Ramhound Jan 2 '14 at 12:37
  • @Ramhound How do I back up the database? – DavidB Jan 2 '14 at 13:06
  • Are you able to verify the MySQL is even running? – Ramhound Jan 2 '14 at 13:11
  • @Ramhound I just reinstalled the notifier, but it didn't fix the problem. When I try to connect to MySQL using MySQL Workbench, the server status is listed as off, so I assume that it is not running, unless something else is wrong with it. – DavidB Jan 2 '14 at 13:44
up vote 6 down vote accepted

I was able to fix the problem with MySQL by deleting settings.config, stored in %appdata%\Oracle\MySQL Notifier. When I restarted MySQL Notifier, the file was automatically regenerated, and guess what? It worked! I found the solution online after hours of searching. Before deleting the old file, I took a screenshot of it open in Notepad++...

Click on image to see full screen version... Old settings.config

After the new one was generated, I opened it up and took a screenshot of it as well. The difference between the two files is rather obvious...

Click on image to see full screen version... New settings.config

I, too, ran across this problem on my local install of MySQL Notifier, and neither deleting settings.config, nor reinstalling had any effect. Further investigation lead me to a file in the same folder with the name connections.xml that only contained a single space character. Deleting that file and restarting the notifier did the trick, though, so if (like me) deleting settings.config doesn't correct the problem, look for connections.xml, and inspect that file for possible problems, deleting when necessary.

Actually you should remove settings.config and also connections.xml from C:\Users\YourUsername\AppData\Roaming\Oracle\MySQL Notifier\ And Start over MySQLNotifier. It worked for me (I have a Windows 7 64bit) but it should work on Win 8 too

I had the same problem on a new installation on Windows 8.1. The settings.config file wasn't in the same location but I had no problem finding it with a dir settings.config /s command. I renamed it just to be safe and then restarted my system. Sure enough, it created a new settings.config file and the error messages went away.

This was the clue I needed to solve the same problem with R4i Viewer (an XML reader). The roaming profile had a filed named settings.xml that contain 2.5 line of spaces. After changing the file extension and opening R4i Viewer, it recreated the settings.xml file and worked properly.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.