2

I have been experiencing an issue with the chromium browser where tabs that I close separately before closing chromium as a whole are reopened with the tabs that I left open when I start chromium again. This behavior is experienced even if all extensions are disabled.

To show what I mean, here is an example of a common scenario:

  1. I have my email, some article, a javadoc page, stack overflow, and a settings panel open in separate tabs on the same window, and with no other windows open.
  2. I click the x button on the tabs for the article, javadoc page, and settings panel, in that order, closing those tabs.
  3. I open another stackoverflow question in a new tab.
  4. I click on the window x button, closing the entire window.
  5. Some time later (including after restarting), I click on the chromium icon in the sidebar, opening the web browser.
  6. The newly-opened window has as tabs: my email, the article I had closed, the javadoc page I had closed, stack overflow, and the stackoverflow question I opened right before closing the browser. (The settings page, however, remains closed, same with any other chrome:// page.)

This is a problem. I do not want those pages to reopen, especially since in other cases it might instead be a dozen tabs with youtube videos or flash applications, all competing for processing power and bandwidth, and freezing the browser when I open it.

How can I fix this problem?


Version info (from the chrome://version page):

Chromium: 31.0.1650.63 (Developer Build 31.0.1650.63-0ubuntu0.13.10.1~20131204.1) Ubuntu 13.10
OS: Linux
Blink: 537.36 (@163124)
JavaScript: V8 3.21.18.13
Flash: 11.2 r202
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/31.0.1650.63 Chrome/31.0.1650.63 Safari/537.36
Command Line: /usr/lib/chromium-browser/chromium-browser --flag-switches-begin --enable-fast-unload --enable-nacl --flag-switches-end
Executable Path: /usr/lib/chromium-browser/chromium-browser

1
  • For some reason, there is no Ubuntu-13.10 tag on superuser yet. Could someone with more rep please retag? Jan 2, 2014 at 20:34

1 Answer 1

0

Assuming that Chrome behaves the same way on Linux as it does on Windows, in your setting have you tried to switch "On Startup" category to "Open New Tab Page"

5
  • Yes, I tried it and that setting functions as it should. However, this is not the same thing. I want only the tabs I left open to reopen, while currently it also reopens several closed tabs alongside them. Jan 2, 2014 at 20:41
  • What setting do you have currently selected: "Continue where I left off" Jan 2, 2014 at 20:42
  • Yes, that is my setting. Jan 2, 2014 at 20:44
  • Have you tried different version? Possible bug with the history of open pages. Jan 2, 2014 at 20:46
  • no I have not. I will try that if no better options appear. Jan 2, 2014 at 21:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .