I am running Linux kernel 2.6.18-371. I have read


and am able to access my windows files from command line using

/usr/bin/smbclient -L <serverName> <passWD>

However, I am not able to get MATLAB to see the windows folder. Is there a work around? Thank you for the help.


This is not Matlab specific. In order for a Linux program to see files in a file system, it has to be mounted. For samba, the mount type is called cifs, i.e. you do something like

mount //servername/share mount-point/ -t cifs

where mount-point is the directory where you want to mount the share. You will then be asked for your username and password; or you can provide them via options. In order for this to work you have to have the right package installed, on Debian it is called cifs-utils.

For more information, see man mount and man mount.cifs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.