I've installed the Markdown Viewer Firefox addon, but I cannot get it to work on my Ubuntu installation. Firefox is my browser of choice and I am trying to move to Markdown in Vim as my basic text-writing software. Is there a way I can get this to work?


Happy to report that I was able to find a solution that I provided here:


I've also copied it here for reference:

On Linux, you'll need to create a new MIME type here:


With the following content:

<?xml version="1.0"?>
<mime-info xmlns='http://www.freedesktop.org/standards/shared-mime-info'>
  <mime-type type="text/plain">
    <glob pattern="*.md"/>
    <glob pattern="*.mkd"/>
    <glob pattern="*.markdown"/>

Then run:

update-mime-database ~/.local/share/mime

| improve this answer | |
  • Could you copy it here? meta.stackexchange.com/a/8259/350309 – Hex Feb 6 '17 at 15:38
  • Thanks! This worked for me in Ubuntu 16.04, Firefox 57.0.3, but only with the Markdown Viewer Webext add-on. With the Markdown Viewer add-on, it just displayed source/plain text. – alaferg Jan 3 '18 at 22:30
  • 2
    Worked for me on Ubuntu 17.10 with FF 59.0.1 and the GitLab Markdown Viewer add-on. – code_dredd Mar 22 '18 at 15:44
  • Thanks, saved my day! – jan groth Dec 28 '19 at 6:01

I had to manually edit my ~/.mozilla/firefox/<PROFILE>/mimeTypes.rdf. This review of the addon says:

For linux users, try to add "md" to .mozilla/*.default/mimeTypes.rdf this line : mdin text/plain section :)

Hmm. I couldn't find a text/plain section, but I found this page is helpful:

If there is not yet an existing RDF node for 'text/plain' add it, and add "md" as a file extension.

<RDF:Description RDF:about="urn:mimetype:text/plain"
       NC:description="Text Document">
   <NC:handlerProp RDF:resource="urn:mimetype:handler:text/plain"/>

However, what I ended up doing was:

<RDF:Description RDF:about="urn:mimetype:text/plain; charset=utf8"
               NC:value="text/plain; charset=utf8"
               NC:description="Markdown Document">
  <NC:handlerProp RDF:resource="urn:mimetype:handler:text/plain; charset=utf8"/>

It seemed to be the NC:handInternal="true" that did the trick. Interestingly, it seems it does not work with the text/markdown or text/x-markdown MIME types. The charset=utf8 is because I write all my Makefiles in Unicode.

| improve this answer | |
  • One have to restart Firefox after modifying the mimeTypes.rdf file for changes to be applied. – iurii Aug 6 '14 at 15:37
  • I just installed the Firefox Markdown Viewer on Kubuntu 12.04 and it worked perfectly out of the box. No tweaks required. – MountainX Jan 17 '15 at 20:17
  • Did not work for me in Ubuntu 16.04 with FF 54.0. @Brad's solution did work. – Keith Robertson Aug 11 '17 at 23:41
  • @KeithRobertson Yeah, this solution is dated. You see it's from 3-1/2 years ago... – Kazark Aug 14 '17 at 17:18

I tried Kazark's solution with no success. So I restored the mimeTypes.rdf file to the default content and it worked.

To do so:

  • In a terminal: firefox --ProfileManager
  • Create a dummy profile and start Firefox with it
  • Then in ~/.mozilla/firefox/, copy mimeTypes.rdf from *.dummy directory to your profile directory (probably *.default)
  • Restart Firefox and test
| improve this answer | |

I was able to solve the same problem by putting the following line into ~/.mime.types.

text/plain                                   md markdown
| improve this answer | |

I installed https://addons.mozilla.org/en-us/firefox/addon/markdown-viewer-webext/ right now. It is a signed Add-on from the official Mozilla Add-ons Repository and it is compatible with multiprocess. Cool. :)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.