0

I brought two Vantec IDE SATA to USB 2 Adapters, as shown below:

enter image description here

It comes with the following items inside:

enter image description here

However, I notice a strange situations as follows:

I use the 1st set and format a hard disk 500GB with a single partition using Windows 7. I was able to use and view the partition.

Then I use the 2nd set to see if I can use and view the partition on the hard disk. I expected that I would be able to use and view the partition with no problem. However, the 2nd set showed me 2 partitions with the 1st partition marked as RAW and 2nd partition as empty.

I found it strange and thus repeated the process by creating a single partition on the hard disk 500 GB and formatting it using Windows 7 via the 2nd set.

Then I used the 1st set to see if I could use and view the partition on the hard disk. This time, I was able to see a single partition, but it was in the RAW format. (Windows will prompt for format the hard disk if the partition is in the RAW format.)

This is driving me crazy. I brought 2 sets of IDE SATA to USB 2 adapter and they give me two different results.

So, I would like to ask which is causing the problem - the 500 GB hard disk, the 1st set or the 2nd set? (What I suspect is that one of the controller is damaged but I was thinking if there are better and faster way to troubleshoot such problem because I also worry if both the hard disk and the 2nd set of adapter are damaged ones or flaky.)

  • So you're saying that each one can only properly see the one that it formatted?!?!?! – barlop Jan 3 '14 at 8:51
  • they're not too expensive. I'd consider buying a different make, as part of the troubleshooting. I've seen a case where with a simple USB-Ps2 adaptor, some worked in all my computers. Some worked in only one of them. So I concluded the ones that worked in all computers were more lenient and better. And I had others that only worked in some computers and not another. I concluded that the computers they worked in were more lenient and thus had better functioning usb ports. I kept the not so lenient computers 'cos i'm not going to chuck those. But I chucked the not so lenient usb-ps2 adaptors. – barlop Jan 3 '14 at 8:57
  • and that's as weird as i've seen. With USB-IDE. I have had a flaky one. And I have had one that just plugged into one USB port and was recognized in one computer and not another. If I were you I would at least get a USB-SATA adaptor that plugs into TWO usb ports and works on a 1.8" or 2.5" SATA hard disk. Those adaptor cables are very cheap. So if you have such a hard disk it's something to try. – barlop Jan 3 '14 at 8:58
  • @barlop Yes, each set of adapter can only properly see the one that it formatted. That's is why I am having a headache on how to troubleshoot this problem. I hope that it is not the hard disk that is the actual problem. – user275517 Jan 3 '14 at 9:24
  • it could be both adapters are an issue. Maybe another make of adapter will see the hard drives formatted by the other two – barlop Jan 3 '14 at 9:56
1

This may be a sector size issue. Newer HDs use 4096-byte sectors, not 512 - and employ a translation layer so the OS sees the HD as having 512-byte sectors (for compatibility).

Problem is some USB adapters ignore the translation and report the drive as having 4096-byte sectors. Other USB adapters use the translation and report the drive as having 512-byte sectors.

So the issue may be: one of your adapters is reporting 4096-byte sectors, the other is reporting 512-byte. As the partition table is sector-based, when you transfer the HD from one to the other, it can't find the partitions.

Try using a GPT partition table on the disk instead of MBR - AFAIK GPT will take care of the sector size issues.

  • So, based on your answer, it means that one of the adapter is flaky... (sednacomputer.com/photo/se-usb-ide-sata.jpg), right? – user275517 Jan 3 '14 at 9:28
  • No, I wouldn't say flaky, just "different". It seems both are working OK. You could check the sector-size with fdisk on Linux to confirm the sector-size issue. – NothingsImpossible Jan 3 '14 at 9:55
  • @user275517 - One thing you can do is verify from the manufacture itself. You can also verify both have the exact same lables. One could be the same product but a different revision, which could have been released years apart, and your vendor sent you old stock. – Ramhound Jan 3 '14 at 12:53
0

In my opinion, the approach to this issue is - if possible/available, connect the drive to the port (ide or sata, depending on the hdd) on a pc with an OS, format it from there. If everything's goes well, issue with hdd is cleared. Disconnect the hdd from the pc and try it on both IDE/SATA to USB bridge and see what comes up.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.