I'm using for a while now, and I just decided to install the new beta of to try new features (keeping ST2 installed). 

I successfully finished the installation, but when I try to install new packages in ST3 (via PackageControl), it seems there's an issue with ST2 already-installed packages.

Let's take SassBuild package as an example.

  • [ST2] Already installed
  • [ST2] This file exists, and is customized C:/Users/$/AppData/Roaming/Sublime Text 2/Packages/SASS Build/SASS.sublime-build
  • [ST3] I launch SassBuild installation via PackageControl
  • [ST3] Installation works well (or it looks like)
  • [ST3] I want to edit the SASS.sublime-build file
  • [ST3] I'm not able to find the folder : C:/Users/$/AppData/Roaming/Sublime Text 3/Packages/SASS Build/

I tried with a few packages, and only new ones (non-installed on ST2) works well.

Any idea to fix/avoid this issue ?
(or any explaination if I'm just missing something)


Sublime Text 3 uses .sublime-package zip files to store packages. In Windows, they are stored in AppData/Roaming/Sublime Text 3/Installed Packages. The easiest way to deal with them is to install the PackageResourceViewer plugin via Package Control. Once installed, it gives you Command Palette options to view, edit, and extract packages. For example, in your case, hit CtrlShiftP to open the Command Palette, then type prv to bring up the PackageResourceViewer options. Select PackageResourceViewer: Open Resource, navigate to SASS Build, then select SASS.sublime-build from the menu. Make any changes you want and save the file - it will now be located in AppData/Roaming/Sublime Text 3/Packages/SASS Build/SASS.sublime-build, and will override the default version in the .sublime-package.

Please note that any files you extract in this way will not be updated when Package Control updates the parent package, so only extract what you actually want to edit. PackageResourceViewer has an option to extract an entire package at once, so just be aware of what will happen if you do that.

Good luck!

  • I have all the same problems as the OP, but in additon, my command Pallette cannot find the command Package Control: Install Package. However, using View > Show Console revealed all the correct paths, and finally allowed me to install the PRV.
    – Domi
    Jan 10 '15 at 10:19
  • The PRV plugin worked well to modify a settings file (that was hidden before). But now the plugin I was modifying has stopped working. Any ideas? Aug 21 '15 at 2:19
  • Update: Turns out it's just that doesn't seem to recognize the "ctrl" key in the keymap config... Whatever Aug 21 '15 at 2:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.