6

I'm trying to upgrade a new Dell laptop with Windows 8 to Windows 8.1. Using the default user logon created at initial boot, trying to upgrade to 8.1 via the Windows Store, I get the following error:

"You need to use an account with Administrator privileges to install Windows 8.1, try logging in with the user account of an administrator of this PC and trying the update again."

Putting aside the grammatical error of Windows Store, I can't tell why it is not recognizing admin privileges.

Doing a

"net localgroup Administrators"

lists the username in the group.

Creating an additional user with admin privileges to perform the install seemed to work but I don't understand why the original account didn't.

  • Technically there is nothing grammatically incorrect about the message. By default the User account you created wasn't part of the Administrator group. Its simple enough to change that of course. – Ramhound Jan 3 '14 at 18:50
  • "trying the update again" should be "try the update again". The original user is in the Admin group but Windows Store doesn't recognize it. – Danny D'Amours Jan 3 '14 at 18:55
  • Both versions of the statement are correct. By default the intial user shouldn't have been in the Administrator group. Did you change the user's group yourself? – Ramhound Jan 3 '14 at 18:58
  • No the initial user had admin privileges automatically. Perhaps Dell's customized config did it but in a way that Windows Store doesn't recognize properly? How do you get Admin access if the first (and only) user account doesn't have access, boot into Safe Mode? Does Windows Store check for Admin membership differently than the basic OS? – Danny D'Amours Jan 3 '14 at 19:04
  • The built-in Administrator user account is normally enabled by default. – Ramhound Jan 3 '14 at 19:17
5
  1. Check your user privileges: Windows key + R key (Windows +R) → opens the run window
  2. Type/copy: control userpasswords2
  3. Press enter

    It will open the user accounts window

  4. Double-click your user or select your user

  5. Click Properties
  6. Click Group membership tab
  7. Check if the radio button is on administrators.
  • 1
    This worked for me. Dell OEM of Windows 8.0. User was listed as a member of HomeUsers and Administrators, but when I edited the user priveleges, radio button was not set for Administrators. I set that, and could immediately install 8.1. Thanks. – colmob Feb 14 '14 at 5:57
1

I called Dell tech support. They tried and also failed to update to Win 8.1. They did a bunch of updates, activated Dell backup and ran a command line utility wsreset.exe that cleared the store cache, I'm guessing that is what fixed the problem.

Probably a left over setting from the preinstallation of apps.

0

Creating an additional user with admin privileges to perform the install seemed the only workaround that I could find to install the 8.1 update.

0

The problem is with the Update Make sure I had KB2871389 installed. uninstall restart PC try the update it should work

Faizan Sharif Dell Sr.Engg

  • Could you edit this post to make it more clear. Are you suggesting the OP required your specified update followed by a system restart to clean up the issue? I don't want to edit your post if this is not your intended message. Thanks – Matthew Williams Apr 1 '14 at 14:20
-1

Change your user to admin group like xilolee said. Then, run wsreset.exe to clean the cache like Kevin/Jean said.

Now the store will reset all its information, getting user´s new credentials as admin and letting you install windows 8.1.

protected by Community Apr 18 '14 at 2:30

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.