4

I have tried it with LAN cable and wireless connection and cannot make it work. I have tried creating HomeGroups on both laptops and joining from both but same scenario occurs.

On 1st laptop (Windows 7 Home Premium 64-bit) I get the following and no 2nd laptop (Windows 7 Enterprise 64-bit) is visible:

enter image description here


On 2nd laptop I get the following but when clicking on folders, nothing happens but click sound:

enter image description here


Trying to share public folders or libraries with HomeGroup on 1st laptop (read or read/write) does not do anything, but trying same on 2nd laptop shows this:

enter image description here



What is wrong here? Documents and Pictures folders are shared. All sharing is turned on on both laptops and all connection is set as Home Network which is requirement of HomeGroup:

enter image description here



Here is related problem I currently have and I do not know which should be resolved first.



UPDATE: I just looked at My Computer > System Properties > Computer Name and found out that both laptops are members of WORKGROUP but not Domain. Is that okay? What if I change both to be members of domain?

enter image description here

enter image description here

Also only 2nd laptop has Network ID accessible where I can do the following:

enter image description here



UPDATE 2: Tried connecting user accounts to Windows Live on both laptops to no avail. Tried Safe-Mode With Networking and clean boot to no avail. Tried making Internet Connection Sharing through one of laptops to no avail. Tried obtaining custom IPs to no avail. LAN or wireless network - nothing worked whatsoever, meaning router is not a problem and it seems I am not the only one. Let's hope time will come when Microsoft fixes issue.

5
  • Have you created a Homegroup? Your missing the option to create a Homegroup which indicates you are part of a domain. Is that the case? windows.microsoft.com/en-us/windows7/create-a-homegroup – Ramhound Jan 3 '14 at 19:19
  • @Ramhound I have mentioned that I have created HomeGroup on one and later the other laptop and joined from one after the other. – Boris_yo Jan 3 '14 at 19:29
  • You did exactly what was done in the linked video? There is a MS Fixit that might help ( windows.microsoft.com/en-us/windows7/… ). Lets put it this way. When I created my homegroup I had no problems so there has to be some configuration your missing causing the problem. I was even able to do this across platforms ( Windows Vista -> Windows 7 -> Windows 8.1 ) – Ramhound Jan 3 '14 at 19:30
  • 2
    Can you get to the other PC by IP address? this would be a good test to test connectivity between machines. At the very least try to ping the other IP address. There could be problems with your network settings or firewall that is preventing to see the other machine. Another setting to check would be connection property. Network connection needs to be set as "Home Network" if it set as "Public Network" than firewall would prevent other PC from seeing it. – Vladimir Oselsky Jan 3 '14 at 19:34
  • Both laptops can ping each other and have their conenction set as Home Network. @Ramhound Yes I have created Homegroup, – Boris_yo Jan 4 '14 at 14:16
4
+75

Some more to try, from the article Windows 7 HomeGroup not working? Try these quick fixes :

  • Visit Action Center
    Click the flag icon in the Notification area of the Taskbar and click Open Action Center. Select Troubleshooting > Network and Internet, and click HomeGroup to launch a troubleshooter.

  • Turn off all firewalls

  • Enable IPv6
    Your PCs need to support IPv6 and have it enabled in order to connect to a HomeGroup: from the Network and Sharing Center, click "Change Adapter Settings", right-click your network adapter and choose Properties, then verify the TCP/IPv6 entry is ticked. Ensure also that IPv6 is enabled in the router.

  • Check services
    Press Windows + R, type "services.msc" and press Enter. Check the following services are running: HomeGroup Listener, HomeGroup Provider, Peer Name Resolution Protocol, Peer Networking Grouping and Peer Networking Identity Manager.

  • Rejoin HomeGroup
    Leave the HomeGroup, then delete the contents of the c:\ Windows\ServiceProfiles\ LocalService\AppData\Roaming\PeerNetworking folder – you'll need to click "Continue to" when prompted to access the LocalService folder, and AppData is a hidden folder.

  • Give up on HomeGroup
    Remove the HomeGroup from your main computer, then click "Change advanced sharing settings" and configure your network manually. Once this is done, you can then share any individual folder by right-clicking it and choosing Share with > Specific people.

1

HomeGroup uses multicast IPv6, specifically WS-Discovery.

In the comments you said the computers were able to ping each other, but most likely this was a ping using IPv4 addresses. An IPv6 address uses hexadecimal numbers separated by colons (not to be confused with a MAC address). First check that each computer has an IPv6 address, then try pinging using that address.

Lastly, since IPv6 is relatively new, your hardware needs to support it. As a rule of thumb, you would want to be using computers (specifically, their network adapters) and a router from 2008 or later.

1
  • It's a good answer, but just that IPv6 was already mentioned in a previous answer. – harrymc May 20 '14 at 20:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.