2

I am trying to experiment with GNUS email in Emacs, in Windows (EDIT: x64 bit). I've got it to work in Ubuntu, but struggling with it in Windows.

From

http://www.gnu.org/software/emacs/manual/html_mono/emacs-gnutls.html#Help-For-Users

I read in second paragraph:

This is a little bit trickier on the W32 (Windows) platform, but if you have the GnuTLS DLLs (available from http://sourceforge.net/projects/ezwinports/files/ thanks to Eli Zaretskii) in the same directory as Emacs, you should be OK.

I have downloaded and unzipped the gnutls-3.0.9-w32-bin package, but am not sure what to do with it. I have tried putting it in Program Files (x86), which is "the same directory as Emacs". I have tried putting it in the emacs-24.3 folder. I consider merging all the folders in between the two, but am hesitant as that seems a difficult troubleshoot attempt compared to my knowledge on these matters.

I think Emacs needs to somehow see the gnutls binaries and/or dlls. My knowledge is limited on this. I've also struggled to understand PATHs for sometime now, and am not sure if that approach is relevant here.

FYI, the emacs directory contains folders labeled bin, etc, info, leim, lisp and site-lisp. The gnutls directory contains folder labeled bin, include, lib and share.

Hmm, now I'm finding lots of links on adding paths. Still, I'm skeptical that I would only add gnutls.exe path, as it seems the dlls are needed.


Some additional data for Ramhound's first comment


I have been attempting the (require 'gnutls) route. This seems to be the most relevant parts in the log:

Opening connection to imap.gmail.com via tls...
gnutls.c: [1] (Emacs) GnuTLS library not found
Opening TLS connection to `imap.gmail.com'...
Opening TLS connection with `gnutls-cli --insecure -p 993 imap.gmail.com'...failed
Opening TLS connection with `gnutls-cli --insecure -p 993 imap.gmail.com --protocols ssl3'...failed
Opening TLS connection with `openssl s_client -connect imap.gmail.com:993 -no_ssl2 -ign_eof'...failed
Opening TLS connection to `imap.gmail.com'...failed

I am not sure what "in stallion" means. Emacs seems to have installed itself in program files (x86), so I assume it is 32 bit. I can try and figure out how to double check, but did not realize I would get such fast response time, and am headed out right now.

I will try merging the files later tonight?

5
  • 1
    The DLLS from the GnuTLS /bin directory probably need to go into Emacs' /bin directory. Commented Jan 3, 2014 at 22:33
  • This a x86 or x64 operating system? I already know the answer based on some facts within the question but update the question none the less. Do you know if eMac is running as a 64-bit or 32-bit application? What are the specific problems you face when you run it? The proper location is where the eMac executable is exactly, update the question, to reflect the in stallion directory
    – Ramhound
    Commented Jan 3, 2014 at 22:35
  • @AaronMiller, can I simply "yank them out", with no regard to the rest of the GnuTLS folders? Would this be a good time to create a system restore points, to make it easier to experiment with Program Files? Commented Jan 3, 2014 at 22:42
  • @Ramhound and AaronMiller, thank you for your help, I will be back on later to try these out. Commented Jan 3, 2014 at 22:55
  • FWIW, I wrote up the process that worked for me.
    – legoscia
    Commented Jun 13, 2014 at 15:52

1 Answer 1

0

Not quite the same issue, but I slowly gained a better sense of how path stuff works. I wanted to enable images in Emacs w3m-mode. Perhaps merging the dlls to Emacs directory is the only way. I think editing the Windows PATH variable does not work.

From How to enable Emacs PNG support on MS Windows Yoo Box,

3.2. things that don’t enable PNG support

According to my test with GNU Emacs 24.3.1, following things don’t successfully enable PNG support.

  1. Adding the path to the folder containing the appropriate libpng dll file to exec-path (Elisp variable) and/or PATH (Windows environment variable).
  2. Copying an older version of libpng dll into Emacs bin. (GnuWin32 ones are likely to be old.)
  3. Changing dynamic-library-alist (or image-library-alist) in the hope that it may make Emacs recognize the old libpng file (in 2).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .