Quick description, then more details below.

I have several files that are giving the error message: "The File or directory is corrupted and unreadable" any time they are accessed: Read, Delete, Rename, or try to view their properties. They show up just fine in explorer.

I have tried opening a CMD shell as Administrator and deleting them. I have tried booting into Safe Mode as an administrator and deleting them. I have chkdsk /f multiple times. I have tried downloading Unlocker and Killbox, tools I found referenced in various threads brought up by google. The files remained. It does cause chkdsk to run the next time I boot, but it doesn't remove the file.

More details:

The files are text files that were backed up from an XP machine using Acronis corporate edition backup manager. They were restored on a file basis to a Win 7 directory using Acronis True Image Home (version 11). There are only a handful of files out of a couple hundred that are corrupted, so I don't have reason to think it's the backup/restore sequence that's the key. And I'm not too concerned about them being corrupted - I can restore them from other sources later. Right now I just want to be able to delete them.

2 Answers 2



  1. chkdsk <drive> /f, and if not fixed then chkdsk <drive> /r
  2. Boot with a Linux live CD and delete the files
  • Tried the chkdsk, didn't help. I had thought about using the Linux disk, but I'm really out of my element there. But I may get desparate enough to try it. Right now I'm waiting on a callback from Microsoft support using one of my MSDN support incidents. I've also thought about moving all the good files form that partition to another partition, then reformatting it. Not sure which is more desparate.
    – daveh551
    Nov 12, 2009 at 21:35
  • Spent over 2 hours on the phone with Microsoft Tech support. Ended up with him advising me to go ahead and move the files and reformat. I did move the files, but I downloaded the latest stable Ubuntu release, burned it to CD, booted from it, and successfully deleted the files. It did run chkdsk when the system booted back up, but it appears to have gotten rid of the files!
    – daveh551
    Nov 13, 2009 at 15:56

It's a long shot, but have you tried rmdir /q /s on the folder(s) in which the files reside?

  • Nope, that didn't do it either.
    – daveh551
    Nov 13, 2009 at 0:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.