I just upgraded my Elonex Artisan Media Centre from Vista to Windows 8 (with Media Centre pack).

The upgrade went surprisingly smoothly, once I had added the old sound drivers, and forced Windows 8 to use my old X300 video drivers.

I thought at first the machine was going to be unusably slow, but it turned out the indexing services were using 90% cpu, and after an hour or so the machine became more responsive.

However, I now have a problem. If I press the power button on my Media Centre infra red remote control, the machine appears to shut down (all the lights go out, and it does not respond if I press the remote power button again). If I press the power button on the front of the computer, it starts up again, and goes back to exactly where I left off (perhaps it is hibernating - but it seems awful quick).

If I press Win+I, then sleep from the power menu, it goes to sleep liked it used to - i.e. some of the lights stay on, and the remote will power it up again.

You can also choose Sleep from the Media Centre menus, and that sleeps properly too. It is only the Power button on the remote that shuts the machine down (or Hibernates it - I'm not sure - whatever it does, the machine is powered off, and will not restart from the remote).

  • 1
    I would check what the power button setting in set to under power options in the control panel. – Michael Frank Jan 4 '14 at 23:40
  • There are two settings, one for power button, one for sleep button. Originally the power button was set to shut down, and the sleep button to sleep. I changed it so both were set to sleep - it made no difference. I have tried choosing Tasks/Shutdown/Sleep in Media Centre, and the computer went to sleep as it should. I have also tried at Advanced MCE Remote Mapper Tool, but it says the remote power button is set to Sleep. – Nikki Locke Jan 5 '14 at 12:22
  • I checked the BIOS settings. Power is set to S3 (the highest choice available). Wake on USB is set to on. – Nikki Locke Jan 6 '14 at 11:24

I solved the problem by running powercfg -hibernate off from an administrator command prompt, and then rebooting.

[Credit to cncb on the Green Button forum for suggesting this]

I suspect my previous Vista setup may have had hibernate turned off already, but installing Windows 8 reinstated it. If that is the case, then probably the remote control power button always hibernates if that is enabled, and only sleeps if it is not.

Of course, life would be even better if you could power the machine on from the hibernate state using the remote button, and scheduler could also auto-start the machine from hibernate for recordings - then a small amount of power would be saved. But I am happy for it to be working as it is.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.