5

I understand that I need to log in to wamp server in order to create a database. My problem is that the phpmyadmin page opens without asking me to log in. So, I presume that I am not logged in. If so, I do not know how to log out. I know this is so basic but I am stuck here. Thanks for any advice.

5

The default username is "root" default password is '' (empty/blank).

if u want to know the password go to wamp installation path\apps\ for example C:\wamp\apps\phpmyadmin2.10.1 in this path u can fine the file named 'config.inc.php' open that file with any text editor and search for $cfg['Servers'][$i]['password'] the password had been stored in this variable.

Also check out https://stackoverflow.com/questions/4420894/wamp-server-mysql-user-id-and-password

| improve this answer | |
  • Thanks but I know the username and password but I do not get anywhere to use it. There is no link to log out. It does not ask to log in. Where can I log in or out? Chaski – user3159862 Jan 4 '14 at 9:29
  • Try opening the index.php file e.g.: localhost/phpMyAdmin-3.5.8-english/index.php – KarlosFontana Jan 4 '14 at 9:53
  • if you are presumably logged in, then click on "Databases" tab inside phpMyAdmin, then type in a name for your database and click "Create". – KarlosFontana Jan 4 '14 at 9:56
  • Login without a password is forbidden by configuration (see AllowNoPassword) – Damir Olejar Aug 10 at 20:55
1

Just go to Wamp Directory on your window and check phpmyadmin in apps folder inside wamp.

D:\wamp\apps\phpmyadmin4.1.14

Open config.inc.php and go on line 28.

Just put new password or remove it as per your need:

/* Authentication type */

$cfg['Servers'][$i]['verbose'] = 'mysql wampserver';
//$cfg['Servers'][$i]['auth_type'] = 'cookie';
$cfg['Servers'][$i]['auth_type'] = 'config';
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = '';

| improve this answer | |
  • Welcome on super user. Remember that to go to a new line (without leaving a line empty in the middle) you have to add 2 spaces at the end of the line. . <-- In this way. – Hastur Jul 11 '16 at 14:28
0

If you don't set username and password for wamp server it never asked for it.

| improve this answer | |
0

What I can also recommend is downloading the latest phpMyAdmin from http://www.phpmyadmin.net.
Then unzip the folder to C:\wamp\phpMyAdmin-4.1.3-all-languages
Then launch

    [http://localhost/phpMyAdmin-4.1.3-all-languages/index.php](http://localhost/phpMyAdmin-4.1.3-all-languages/index.php)
   now it should only ask you for username (root) and password (blank/none/empty)
| improve this answer | |
  • I was given the option to log on again after no activity for a certain period of time. I also copied these files as you suggested and now that problem is solved. Thanks for your help. Chaski – user3159862 Jan 4 '14 at 11:39
  • Pleasure! please mark my answer as answered :-) – KarlosFontana Jan 4 '14 at 13:32