1

I have two routers and I want to extend my Wi-Fi range.

First router: TP-Link AC1750

  • directly connected to cable modem (192.168.11.1)
  • SSID is main_router
  • DHCP is enabled

Second router: TP-Link TL-WR1043ND

  • IP: 192.168.11.2
  • Gateway: 192.168.11.2
  • SSID is: secondary_router, this one is bridged to main_router
  • DHCP is disabled

Both router have the same start and end IP address (for LAN).

My laptop is connected to main_router (5 GHz network, but 2.4 GHz is also available). But most of the time I get an empty webpage and I need to refresh the web page until it's OK.

Wi-Fi is used to connect the secondary_router to main_router.

@majenko said that both router need to operate in bridge mode, but I don't know how or if this is even possible with my used hardware.

  • 1
    Why gateway 192.168.11.2 for the second router, should be the cable modem 192.168.11.1, there is probably a mistake in your question. – Vojtěch Dohnal Jul 19 '16 at 11:20
  • You are approaching this all wrong. First, lease see #2 from this PDF: wirelessaction.files.wordpress.com/2016/09/… - with that being said, you need a wireless access point, a.k.a those things you see in ceilings in public places, sometimes schools. Those are not routers. Routers send data between 2 networks; you don't need that capability it sounds like. This is all explained in more detail here: youtube.com/watch?v=6i777lddg8s – InterLinked Apr 30 '17 at 20:02
1

Enable DHCP on R1 connected to modem with range 192.168.11.3 to 192.168.11.254.

Disable Dhcp on R2.

Configure ip address 192.168.11.2 on then LAN of R2, no hosts will use this IP anyway, it is just a placeholder as some routers require it.

Connect R1 and R2 by ethernet cable using any of the LAN ports, not WAN, because we need to switch between them, we don't want to route.

If you try to connect your pc to R2 wifi, the pc will broadcast DHCP request, R2 will ignore the request, but as it is broadcast it will go through the cable to R1, then R1 DHCP will respond with IP address and default gateway 192.168.11.1.

Make sure no VLANs are blocking the switching path between R1 and R2.

  • both router are too far, that why i want to connect them using wifi – redfox26 Jan 5 '14 at 14:52
  • If you want to connect both routers via wifi then R1 should run as access point and the other as repeater or WDS. – aseaudi Jan 5 '14 at 15:08
  • ok so my current config should be except maybe R2 who use 192.168.11.2 for it's gateways... should use 192.168.11.1? seem like the way to go: tp-link.com/lk/article/?faqid=263 – redfox26 Jan 5 '14 at 15:16
  • "Connect R1 and R2 by ethernet cable using any of the LAN ports, not WAN, because we need to switch between them, we don't want to route." - that was the key, thanks! – 101 May 30 '19 at 2:12
0

I managed to solve this problem by taking a D-Link DAP Router and setting it to Bridged Mode. Attached it to the Main Network and the. Just plugged 1 of the 4 ports into my old router that I am using to extend the signal. So I solve the long Ethernet cable problem by using a Bridging capable device to do the job. I did not have to change any of my DHCP settings on my main network but I did have to change the following on my extended network:

  • DNS: Set to the Main Router
  • DHCP: Disabled
  • Default Gateway: Set to the Main Router

http://i.stack.imgur.com/ml43E.jpg


http://i.stack.imgur.com/kn1zA.jpg


i.stack.imgur.com/pqfom.jpg

  • I have a spare router lying around. I need to test this sometime. – Raju Devidas Sep 24 '18 at 16:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.