When downloading an executable file in Firefox (26) windows shows the "File Access - Security warning". Since I am not stupid and don't try to execute downloaded files I don't trust and clearly don't need to be asked again every time I download something I'd like to disable this annoying warning.

2 Answers 2


For when setting browser.download.saveZoneInformation to false doesn't seem to work, one can try applying the following .reg file:

Windows Registry Editor Version 5.00

; Do not preserve zone information in file attachments

Verified to work on Firefox 31, without rebooting the system, and even without restarting Firefox.

For information on the SaveZoneInformation Group Policy registry setting, see https://support.microsoft.com/kb/883260.


As mentioned in this bugzilla entry, there is a new about:config option that controls this behavior. Setting browser.download.saveZoneInformation to false disables it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .