4

I am using 7-zip to split a large folder (>200 GB) into chunks of 4.7GB so that I can burn them onto a DVD. But for now, I am storing these chunks in an external hard disk which has ~300GB of space. There is also >200 GB in the the drive where the folder currently reside.

But when I ran the operation, it gives a "Not enough space on disk error", and even when I deal only with a subfolder (>40 GB) this still occurs.

How do I fix this?

4 Answers 4

7

This is because your 'chunks' are bigger than 4GB. Hard drives formatted to FAT32 can only hold files with a maximum individual file size of no more than 4GB (or abouts).

You should clear your hard disk and reformat it to NTFS, where the maximum filesize is in the region of Exabytes (way more than any hard drives available today. This should be able to stop the "Not enough space on disk error"

Source 1Source 2

2
  • 2
    It is not necessary to clear the disk – Windows has a convert /fs:ntfs command for direct conversion. Jan 6, 2014 at 19:26
  • Didn't know that! That's probably a better way. For n00bs like me, this article talks through everything step-by-step. tweakandtrick.com/2012/02/…
    – dayuloli
    Jan 6, 2014 at 19:32
5

According to the author of 7-zip at the following link, there's a bug where dragging and dropping from the 7-zip window to Explorer can cause this. I don't know if it's been fixed in later versions, but I'm still seeing it in a circumstance where I can't test the later versions, so I thought I'd post it: https://sourceforge.net/p/sevenzip/discussion/45797/thread/21b7bbab/#5ac1

2
  • 1
    This exact thing just happened to me. Using the menus in 7-zip and specifying the path to extract to worked just fine. Thanks a bunch for posting this!
    – Shrout1
    Apr 20, 2020 at 16:33
  • it hasn't been fixed - dragging and dropping causes the error, but clicking "Extract" and then specifying the location works
    – mcmillab
    Aug 11, 2020 at 3:43
-1

I got this issue when I dragged and dropped it into another drive's folder. I realized the program checks the metadata (namely the available space) of the wrong drive, and then says there isn't enough space. The solution for this particular instance of the problem is to move the file to the drive with enough space before extraction.

1
  • 1
    no, it's not wrong. When you drag and drop to another drive then the files are extracted in the temp directory before moving to the other drive, and it's the drive containing /temp that has problems
    – phuclv
    May 20, 2022 at 1:20
-1

Instead of dragging and dropping the file, I right clicked on the archive and chose to extract it that way. This worked for me.

1
  • 1
    this has nothing to do with the OP's case where they're using FAT32
    – phuclv
    May 20, 2022 at 1:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .