0

I have troubles connecting my Samsung Galaxy S4 (Android 4.2.2) to our Exchange server using the stock mail app. A colleague of mine also has an S4 and he has no troubles connecting it, using the same Android version etc. This is what I see in the debug log:

Logger 
Logger     -------------- New Log --------------
Logger     Model      :GT-I9505
Logger     Build      :I9505XXUEMKF
Logger     ChangeList :2082040
Logger     -------------------------------------
2013-12-30 17:56:50:792 7910 9120 [AsyncTask #1] ExchangeService| !!! EAS ExchangeService, onCreate
2013-12-30 17:56:50:796 7910 7910 [main] ExchangeService| !!! EAS ExchangeService, onStartCommand, startingUp = false, running = false
2013-12-30 17:56:50:802 7910 9662 [Binder_4] AbstractSyncService<825>| Testing EAS: owa.ithost.be, ithost\ooms.veerle;null, ssl = 1
2013-12-30 17:56:50:812 7910 9662 [Binder_4] EmailProxy| host = null
2013-12-30 17:56:50:819 7910 9662 [Binder_4] EmailProxy| port = 0
2013-12-30 17:56:50:820 7910 9662 [Binder_4] ExchangeService| getClientConnectionManager ssl = true, port = 443
2013-12-30 17:56:50:826 7910 9662 [Binder_4] EasSynService| create and return deviceType : SAMSUNGGTI9505
2013-12-30 17:56:50:829 7910 9662 [Binder_4] EmailProxy| host = null
2013-12-30 17:56:50:830 7910 9662 [Binder_4] EasSynService| getUserAgent()
2013-12-30 17:56:50:831 7910 9662 [Binder_4] AbstractSyncService<825>| sendHttpClientOptions(): URI String:https://owa.myServer.be/Microsoft-Server-ActiveSync?Cmd=OPTIONS&User=myDomain%5CUser.Name&DeviceId=SEC19D1971555700&DeviceType=SAMSUNGGTI9505
2013-12-30 17:56:50:832 7910 9662 [Binder_4] AbstractSyncService<825>| Authorization:***********
2013-12-30 17:56:50:834 7910 9662 [Binder_4] AbstractSyncService<825>| MS-ASProtocolVersion:2.5
2013-12-30 17:56:50:835 7910 9662 [Binder_4] AbstractSyncService<825>| Connection:keep-alive
2013-12-30 17:56:50:836 7910 9662 [Binder_4] AbstractSyncService<825>| User-Agent:SAMSUNG-GT-I9505/101.403
2013-12-30 17:56:50:842 7910 9662 [Binder_4] EmailProxy| host = null
2013-12-30 17:56:50:845 7910 9662 [Binder_4] EmailProxy| port = 0
2013-12-30 17:56:50:847 7910 9662 [Binder_4] ExchangeService| getClientConnectionManager ssl = true, port = 443
2013-12-30 17:57:05:874 9094 9104 [Binder_1] EmailProvider| EmailProvider.query: uri=content://com.android.email.provider/hostauth?limit=1, selection : protocol="eas" match: 16384
2013-12-30 17:57:05:927 7910 9120 [AsyncTask #1] ExchangeService| !!! EAS ExchangeService, stopping self
2013-12-30 17:57:30:888 7910 9662 [Binder_4] AbstractSyncService<825>| executePostWithTimeout(): Unexpected exception org.apache.http.conn.ConnectTimeoutException: Connect to .. timed out
2013-12-30 17:57:30:890 7910 9662 [Binder_4] AbstractSyncService<825>| IOException caught: org.apache.http.conn.ConnectTimeoutException: Connect to .. timed out
2013-12-30 17:57:30:898 7910 7910 [main] ExchangeService| !!! EAS ExchangeService, onDestroy
2013-12-30 17:57:30:900 7910 7910 [main] DiscourseLogger| Service=destroyed sStop=false sServiceThread=Died
2013-12-30 17:57:30:925 9094 9377 [AsyncTask #3] EmailServiceProxy| validate returns 1
2013-12-30 17:57:30:928 9094 9094 [main] Email| message : null
2013-12-30 17:57:30:936 9094 9094 [main] DiscourseLogger| email=user@aDifferentDomain.be status=failure reason=Cannot connect to server
2013-12-30 17:57:32:699 9094 9094 [main] Email| EmailFeature    CscFeature_Email_EnableOnDeviceHelp: false
2013-12-30 17:57:33:693 9094 9094 [main] Email| EmailFeature    CscFeature_Email_EnableOnDeviceHelp: false
2013-12-30 17:57:34:213 9094 9094 [main] Email| EmailFeature    CscFeature_Email_EnableOnDeviceHelp: false
2013-12-30 17:57:39:438 9094 9094 [main] Email| EmailFeature    CscFeature_Email_EnableOnDeviceHelp: false
2013-12-30 17:57:39:441 9094 9094 [main] AccountSetupExchange| Had to set CBACert in onNext = null
2013-12-30 17:57:39:443 9094 9609 [AsyncTask #5] EmailProvider| EmailProvider.query: uri=content://com.android.email.provider/hostauth, selection : address like ? and login like ? and protocol not like "smtp" match: 16384
2013-12-30 17:57:39:447 9094 9609 [AsyncTask #5] EmailProvider| EmailProvider.query: uri=content://com.android.email.provider/account, selection : emailAddress='user@aDifferentDomain.be' COLLATE NOCASE match: 0
2013-12-30 17:57:39:464 9094 9094 [main] Email| AccountCheckSettingsFragment onActivityCreated
2013-12-30 17:57:39:465 9094 9094 [main] AccountCheckSettingsFragment| CM Test!!! default case= 4
2013-12-30 17:57:39:468 9094 9118 [AsyncTask #1] Email| Begin check of incoming email settings
2013-12-30 17:57:39:487 7910 7910 [main] DiscourseLogger| Service=created sStop=false

I tried connecting with the FQDN of our domain (myDomain.local) as I read this could be an issue. Also tried connecting without SSL. I'm sure my credentials are correct but it seems like the connection times out but I don't know why...

  • I had the same issue with a different client on a touchViz based Samsung phone. It worked only once and at that time it showed "preparing for inintial sync" or something. I had tried to reset the phone and connect thinking that it would work if it was again the "initial sync" but it didn't. :( – dbza Jan 16 '14 at 6:23
0

My firewall blocked the traffic between my phone and the Exchange server. That's why the connection timed out. After allowing Exchange traffic to pass, everything worked like a charm.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.