131

I'm using windows 8.1 with multiple languages. The new pretty shortcut windows+spacebar will pop up a pretty looking selection on the right.

Now, hitting Alt+Shift (left ones) will also change the language.

This 2nd option clashes with some of my other shortcuts (mainly sublime text), and I can't find where/how to disable it. I remember it was possible in previous versions of windows where you could select the shortcut for changing languages.

Any suggestions?

3
  • You can try something like Autohotkey – Ramhound Jan 7 '14 at 11:39
  • @Ramhound to do what? I've used it to create hot keys for things, but wouldn't the default windows take precedence over it? – Noctis Jan 7 '14 at 13:42
  • Autohotkey can allow you to override shortcuts. – Ramhound Jan 7 '14 at 13:51
168

Good golly ... spent too much time on it, but found it eventually.

It's hidding in: Clock,Language, ande Region -> Language -> Advanced Settings -> Change language bar hot keys. (the last is in the "switching input methods").

Here's a website with screenshots .

Once done, you can change or disable it. (which made me realize i have another program that was trying (yet failing) to use those shortcuts :) ).

enter image description here

8
  • 14
    Windows 10 the path is slightly different, Control Panel\All Control Panel Items\Language\Advanced settings – JohnC Apr 25 '17 at 10:00
  • original question was for 8.1 :) . I guess your comment will help people with ... more modern windows ... – Noctis Apr 25 '17 at 10:26
  • 3
    I can't find the path described by @JohnC. I think Windows 10 has changed its location. – Andre Soares Nov 27 '18 at 22:13
  • 4
    @Andre-Soares, look at Andrew Ward's answer to this question, I verified that his sequence works on my Windows 10, build 17134.407. In summary, Windows Settings (formerly Control Panel) > Time & Language > Region & language > Advanced keyboard settings > Language bar options > Advanced Key Settings > Change Key Sequence. Way too long a sequence. – JohnC Nov 29 '18 at 2:25
  • 1
    Couldn't navigate to it so I searched for advanced keyboard settings – CervEd Dec 2 '19 at 16:18
74

Windows 10

February, 2021

This comment reports solution works on Windows 2004 also.

  1. Press the Windows key, type Advanced keyboard settings and then press Enter
    Windows Search for 'Advanced Keyboard Settings'
  2. Input language hot keys (left)
    Select 'Input language hot keys'
  3. Change Key Sequence... (for "Between input languages")
    Select "Advanced Key Settings" tab, and press "Change Key Sequence"
  4. Set to "Not Assigned"
    enter image description here

I'm going to update the subtitle date when this gets an upvote so that we know it's still relevant.

(Thanks @bugybunny, @Bassie-c, and @skajfes for improvements.)

15
  • 2
    Confirmed working in february 2019. – Nict Feb 18 '19 at 20:17
  • 4
    I am on 1809 and connected to a domain and in the settings I had Region & language split up. I had to click on Language, Spelling, typing & keyboard settings on the right (under Related settings) then scroll to the bottom and then on Advanced keyboard settings. The rest is the same Edit: just noticed that you can also press Win key and search for “Typing settings” and then find Advanced keyboard settings at the bottom. – bugybunny May 14 '19 at 12:26
  • 1
    Still working!! – Thomas Cheng Oct 14 '19 at 7:56
  • 1
    Ah, I found were it is. I basicly followed @bugybunny 's road I see now. But a quicker way would be to go to Devices -> Typing and than the Advanced keyboard settings are on the bottom. – Bassie-c Oct 30 '19 at 22:56
  • 1
    @Bassie-c good call. I'll work on updating this. – Reed Dunkle Oct 31 '19 at 20:07
46

Under Windows 10, another lazier way to achieve the same goal is to run the following command line.

"C:\Windows\system32\rundll32.exe" Shell32.dll,Control_RunDLL input.dll,,{C07337D3-DB2C-4D0B-9A93-B722A6C106E2}{HOTKEYS}
5
  • 11
    That was the only working way for me to open that dialog. Thank you very much! – yaskovdev Jun 1 '18 at 7:35
  • This command made my day. I gave up trying to find the dialog in the control panel. Its just complete rubbish, at this point. – birgersp Jan 18 '19 at 22:24
  • Fantastic, for win 2019 server this was the only way to resolve! Thank You much! – Gennady G Aug 15 '19 at 17:39
  • Should be marked as answer. It is difficult that Microsoft is moving (and removing) ui elements. – user718960 Apr 9 '20 at 8:26
  • Worked on my company Laptop where the "Input language hot keys" option was (intentionally or accidentally) disabled, thanks a lot! – A. Markóczy Dec 17 '20 at 10:43
9

The option seems to have moved yet again for the latest Windows 10 update, at least for me (I no longer have a "Language" icon in the Control Panel).

Open the Region & Language settings applet.

Then "Advanced keyboard settings" in Related settings on the right.

Then "Language bar options".

The "Text Services and Input Languages" dialog will appear. Select the "Advanced Key Settings" tab and you'll be shown a Key Sequence list for changing between input languages.

3
  • Hmmm... i still have it no mine. But maybe there's an update coming. Do you have multiple languages set up on your machine ? (I've updated the question title since it seems to be so popular it moved to Win 10 :) ) Cheers. – Noctis Jun 6 '18 at 1:24
  • I have three keyboard languages installed, currently using English (USA) as language, but different keyboard layout. I went to Settings App->Time & Language->Language->Spelling, typing & keyboard settings (in related settings)->Advanced keyboard settings->Language bar options->Advanced key settings and then set Unassigned in key sequence for the option "Between input languages". – Nict Feb 18 '19 at 20:14
  • no longer working – user718960 Apr 9 '20 at 8:31
0

On the new windows I figured it out:

in the windows taskbar search for language settings

click on choose an input method to always choose as default (at the bottom)

language bar options

advanced key settings tab

select between input languages and press the button change key sequence

press both radio buttons on "not assigned and press ok

then press apply

Not the answer you're looking for? Browse other questions tagged or ask your own question.