My home network consists of my ISPs router (Thompson TG585 v8) which is giving out both WIFI and Ethernet LAN connections on the 192.168.1.x range. The router's LAN address is This set-up works fine for all my client computers except in one case:

I have to connect to a client's VPN, and I am using the generic VPN Windows connection to do that (as per their instruction). The VPN connection fails, and I was told by their security guys that the reason is that my IP address is in the 192.168.1.x range, which is the same as their network's.

Question 1: Why does it matter that my internal IP address is on the same range as theirs? Using other VPN clients like CISCO client for other customers whose internal network is in the same range works just fine. Maybe something different with this type of VPN?

Question 2: I also have a Linksys WRT54GS router which I am currently using as a gateway to extend my WIFI range in the office. Can I use it as a router to create a 10.10.1.x subnet, so as to connect with it to the VPN instead? I have tried to switch its Advanced Routing mode to Router (from Gateway), and tried to configure Dynamic routing, as well as static routing, but in both cases it does not work; My PC gets the 10.10.1.x IP address, and I can ping the (the Linksys router's LAN IP address), and even ping (the Linksys router's WAN IP address). But I cannot ping my Thompson router's IP ( Furthermore, from a PC in the 192.168.1.x network I cannot ping the Linksys router's WAN IP address (

Do you have any ideas as to what the problem might be in this case? I have not defined any routes on the Thompson router, and no, I cannot change its internal DHCP network to use the 10.10.1.x range. It is locked I think from my ISP.

  • 2
    Just change your router DHCP to do 192.168.100.x there is no need to go to a different class. – Vladimir Oselsky Jan 7 '14 at 19:43
  • You never confirmed if VPN worked on Linksys/new-network!? The Linksys won't respond to pings on its WAN port for security since it thinks thats the internet. Pings from Linksys network to thompson IP/network don't work because linksys is only aware of its network & your ISP DNS isn't aware of an internal 192.168.1.x network (NAT/security reasons). So all of this is working BY design, you're just connecting things in an odd fashion (not wrong necessarily) & you won't get what you want entirely. – gregg Aug 13 '18 at 14:27
  • As @VladimirOselsky advised I think the solution is to change DHCP scope/range on Thompson. If you can't connect everything to Linksys, then Linksys is only think connected to Thompson. However you are still double-NAT'ed so its really preferred to change Thompson or ask ISP to put it in 'brigde mode' – gregg Aug 13 '18 at 14:30

1.a router connects different subnets together and every port of a router should be connected to a different subnet the reason is that when a packet destined for a certain IP address arrives to the router then the router checks its routing table to find the right destination for that packet but if there are two ports with the same subnet which way should the packet go? VPN connection is like connecting two networks together using ports of a router.
2.The best solution is to change your Thompson TG585 v8 router to use some other subnet (like 192.168.2.x) for your local network.
I don't know anything about your Thompson router but if there is a VLAN option in its settings you may be able to add a new subnet using a new VLAN.

| improve this answer | |

I'm relatively sure that this is NOT an addressing issue. Presumably you are trying to connect to this client's VPN across the internet... so regardless of what address your home router gives out, when you go out to the internet that "home" subnet gets NAT'ted (address translated) to the globally routable address that the provider has assigned to you. If the firewall/VPN connection is anything that requires more than a single return port, when the packets come back from the client to your machine, your router will have no way of getting them back to you.

I think the next step for you is to look for similar problems that are focused on solving NAT issues - again I don't think this has anything to do with how your particular home network is addressed (and changing the subnet or creating a different one) is not likely to help - the problem is in the return path back to your "real" address.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.