I have to run Mac OS on virtual box for a class and it keeps giving me errors stating

"VT-x/AMD-V hardware acceleration not available on your system. Certain guests (e.g. OS/2 and QNX) require this feature and will fail to boot without it."

If there is a solution, I am not used to windows 8.1 and will need detailed instructions on how to fix it. Thank you

  • Either you do not have the options for Virtualisation turned on in your BIOS, or your processor does not support it. Could you supply the exact model number of your laptop? Should be something like M7-XXXxx – Michael Frank Jan 8 '14 at 3:07
  • 1
    I'd suggest you verify that your CPU supports virtualization on Intel's ARK. Just because it is an i7 does not mean that virtualization is supported or enabled. If it is, check your bios settings. – nerdwaller Jan 8 '14 at 3:11
  • is your system a Mac? If not, you're not allowed to run MacOS in a VM. – magicandre1981 Jan 8 '14 at 5:29
  • 3
    This question appears to be off-topic because it is about using software in violation of its license. (Apple does not offer a license to use Mac OS on an HP machine.) – David Schwartz Jan 8 '14 at 6:05
  • Reasonable comment but I disagree. You are assuming that Apple are able to enforce this condition in a license, and depending on location they may not be able to. (For a number of reasons, fair use being one) – davidgo Jan 10 '14 at 7:59

You don't have to uninstall/reinstall HyperV

I ran into this same issue using the new Visual Studio 2015 Android emulator and Windows Phone emulator, while also trying to run VirtualBox clients. Unfortunately you can't run VBox at the same time as the other emulators; you just have to setup a new boot option and reboot to switch back and forth.

Open an administrative command prompt and run:

C:\>bcdedit /copy {current} /d "Windows w/ HyperV"
C:\>bcdedit /set hypervisorlaunchtype off

This will copy your current boot settings to a new boot option called "Windows w/ HyperV" and then will disable HyperV under your current boot option. You can run "bcdedit" with no parameters to check that {current} has the hypvervisorlaunchtype set to "off" and that the new section has hypvervisorlaunchtype set to "auto"

See Scott Hanselman's article for more information.

Do you have Hyper-V installed? For example it may have been added if you installed the Windows Phone emulators which come with Visual Studio 2012 & 2013.

If so, then there is a known conflict between Hyper-V and VirtualBox - Hardware Virtualisation support not detected if Hyper-V installed.

A similar problem occurs trying to use Intel HAXM to accelerate Android x86 Virtual Devices - Windows 8 - How to install Intel HAXM after installing Hyper-V.

Uninstalling the Windows Phone emulators and turning Hyper-V off in Control Panel >> Programs and Features >> Turn Windows features on or off seems to be the only workaround for the moment.

  • 1
    +1: I saw others suggest Hyper-V, but I didn't think I had it installed until you pointed me to the Windows Phone Emulators. – Virtlink Oct 29 '14 at 9:34

For anyone else who may look this up in future. I had the same problem. Turns out virtualization had been disabled in the bios. Check if this is the case. If so, just enable it and the error is gone

As previous replies have said, check if your processor supports VT-x virtualization. If it doesn't, then you just won't be able to run Mac OS on VirtualBox. If that is the case, consider VMWare Player, which is a decent alternative for VirtualBox, and is also free. It is commonly used in computers whose processors don't support VT-x to emulate Mac OS.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.