1

My girlfriend's laptop is a brand new Lenovo Ideapad S400 Touch. I saw the free upgrade to 8.1 and thought it would be a good idea to do. But upon reboot it is no longer able to connect to the wireless network.

It has the broadcom wireless card in it. I went into the device driver settings and made sure that the settings under advanced "should" give the laptop access to the network.

Prior to upgrading from Windows 8 I was able to connect to the wireless network.

I tried downloading and installing the latest Windows 8 wireless drivers for the system. But that had no effect. I have been trying various settings and rebooting. No luck.

Now just to be clear, when I go to connect from that laptop I can see and click on the the name of the wireless network and try to connect. I am just unable to. I verified and re-verified the password for the network multiple times.

I am not sure what could be causing this at this point. Any ideas or suggestions are welcome.

Thanks, Patrick

  • which encryption does your Wifi uses? – magicandre1981 Jan 8 '14 at 18:38
  • WPA2 PSK if I remember correctly. Is there a known issue with that in Windows 8.1? Because that would be awesome (and just another reason to go for Linux). – Patrick Jan 8 '14 at 22:25
  • WPA2 PSK should work. WPA no longer works in 8.1. – magicandre1981 Jan 9 '14 at 5:12
  • Sorry, just got home. It is WPA2-Personal using AES encryption. I saw some information about regular WPA not being available in 8.1. But in my case that would not apply. That and it sees the network. It just can't connect. – Patrick Jan 9 '14 at 6:03
1

First just try changing the settings manually from the command prompt:

netsh wlan set profileparameter name=nameofnetworkprofile authentication=WPA2PSK encryption=tkip

Otherwise, you will have remove the profile and recreate it:

  1. Go to command line, preferably Administrator (have not tried without).

  2. C:\Windows\System32> cd \Users\<User>\Documents

  3. C:\Users\<User>\Documents> netsh

  4. netsh> wlan

  5. netsh wlan> show profiles

  6. delete profile name="<yournetwork>"

    • Enclose the name of network within quotes, this is to ensure that you can cleanly set up the right profile. Don't close the netsh, we'll need it some more. If you do, just reach there the same way as before.
  7. Right click the connection icon in lower right corner > open Network and Sharing Center > Set up a new connection or network > Manually connect to a wireless network

  8. Try to create a profile, and try to get as many details to correspond with your requirement. The rest we will edit on the command line, so let's make it as easy as possible.

  9. Do the same at the next screen. Edit Network settings > change all the parameters that you can, to match your environment.

  10. Finish. Move back to your netsh terminal

  11. netsh wlan> show profile <profilename>

    • Without quotes this time. This should show your previous attempt at creating a profile in the GUI dialog boxes. In my case, it had WPA2 and AES. It has to become WPA and TKIP. I also set my authMode to userOnly, since I hadn't done it right in the dialog box before.
  12. netsh wlan> set profileparameter

    • Displays a humongous list of parameters with detailed options, just carefully examine the syntax. It's all here.
  13. netsh wlan> set profileparameter name=<profilename> authentication=wpa encryption=tkip authMode=userOnly

  14. netsh wlan> set profileparameter

    • Don't exit this yet.
  15. Now click the connection icon, and connect to the network. It will ask you the username and password in a different style, that was my clue something was different this time.

  16. It should connect. In my case, at least, it did. Verify by browsing.

  17. netsh wlan> export profile name="<profile name>"

    • In order that you're not put through this ordeal again, export the profile safely to a file. Again, the profile name in quotes.

ref: http://en.community.dell.com/support-forums/network-internet-wireless/f/3324/t/19528910.aspx

ref: http://www.tomshardware.co.uk/answers/id-1849258/aes-tkip.html

ref: https://social.technet.microsoft.com/Forums/en-US/290c63b4-ce04-4483-a047-e1000c7d7699/wpa-security-types-are-missing-after-upgrading-to-windows-81?forum=w8itpronetworking

  • hi @David it seem i have the same problem. I just wanna know if this will fix the problem with all profile or i should do it for every one – Ayoub Sep 18 '15 at 8:42
0

Looks like you're not the only one. I am having the same trouble connecting when I try to use encryption on a brand new Acer with Windows 8.1 (upgrade from 8.0) I've just spent 4 days learning about routers and trying to secure wireless but not getting encryption to work. My problems are similar, get connected without encryption, but not being asked for password. With encryption, recognized my network and does not connect. I just found this answer: Windows 8 unable to connect to WPA2 AES Wireless Network

  • In your case, was it the manufacturer's wireless management app also causing the problem? – David May 3 '14 at 11:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.