1

I cannot connect to a server with a custom screen resolution set If I use command xfreerdp servername -g 1280x1024 it connects but the resolution is 1024x768. Xfreerdp just carelessly ignores the -g parameter. Any ideas how to fix it or some suggestions for alternative RDP client? It is freerdp-x11 1.0.1-1ubuntu7 amd64 RDP client for Windows Terminal Services

and I use Ubuntu 12.10 64bit. Thanks

4

I had got the same problem for a long time with xfreerdp in Debian 7. It's a bug because I finally found the reason which concerns the positional parameters on the command line!

-g option is always ignored when after -d option!

Here's my test :

-g option fails when after -d option

-g option succeeds when after -x -a or -u option

Hope this will help...


EDIT : -t option and -p option fail after -d option

So the rule is : option -d must be the last on the command line!

  • 3
    This was also helpful to me, thanks. Just to make it clear -- even if not using the -d parameter explicitly, one should add the server in the end, e.g., xfreerdp -u username -g 1280x1024 127.0.0.1. – iled Jun 16 '16 at 11:35
1

In the recent version that I have (version 2.0.0-rc4), one should use /size:WxH option:

    /size:...   Screen size

The -g and -geometry options are used for other purposes:

    /g:<gateway>[:<port>]       Gateway Hostname

    /geometry                   Geometry tracking channel

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.