39

I have a mapped network drive, on which I store some programs, one of which I've put in my startup folder.

Unfortunately, this program "does not have a valid digital signature", which means that every time I reboot, I get a security dialog, asking me whether to run it.

I would prefer not to have to copy this program to the local disk.

How can I disable this prompt?

4 Answers 4

52

Ok, I found the solution.

  • Go to Control Panel -> Internet Options -> Security -> Local Intranet -> Sites -> Advanced
  • Add the mapped drive or UNC path (eg. Z:\ or \\machine)
7
  • Do I remember a box to tick for a permenant connection?
    – Guy Thomas
    Nov 13, 2009 at 8:20
  • When mapping the drive, yes.
    – Blorgbeard
    Nov 15, 2009 at 19:52
  • Thank you, this is the solution that allows me to finally use my shared VirtualBox folders to keep all of my portable windows utilities. It works on XP too.
    – Matt
    Jan 5, 2013 at 12:16
  • Something may have changed (April 2014). The dialog won't let me add a drive letter, e.g. X:\ and X: and file://X: all result in "you have entered an invalid wildcard sequence" (screenshot: i.imgur.com/um529J4.png) (Win7 Home Premium x64) Apr 11, 2014 at 5:09
  • 1
    @matt wilkie To add a whole folder (in this case, the root folder), you should have to specify a wildcard at the target directory. So, it should look like X:\*. At least, this was the case in my experience.
    – Bret
    Mar 1, 2016 at 19:27
6

If your Internet Settings are tied down (as mine are), but you have access to the exe, you can try the following in a command prompt:

move oldName.exe > newName
type newName > oldName.exe

That will remove the stuff that causes Windows to care, which, I think, is stored in an alternate data stream.

2
  • Thanks, that worked even if I can't change settings in Internet Options
    – rofrol
    Jan 2, 2017 at 22:37
  • But probably there is mistake. This worked for me move oldName.exe newName and type newName > oldName.exe
    – rofrol
    May 15, 2017 at 10:16
4

The top answer didn't work for me I had to change a different setting in the same panel.

What I changed was: From Go to Control Panel -> Internet Options -> Security -> Local Intranet -> Sites -> Advanced (Same as above) In the "Local Intranet" settings window I unchecked "automatically detect intranet" and checked "include all network paths" which will work for me in my virtual environment.

Local Intranet settings

0

You can use "automatically detect intranet" and then add the UNC path in the format of "file:\sharename" (if letters are mapped to this location, should work for them too)

4
  • Duplicate of the accepted answer
    – user477799
    Mar 31, 2017 at 17:57
  • I disagree; all syntax variations in the "accepted answer" failed. This syntax works. Apr 11, 2017 at 15:28
  • Disagree all you like. At the end of the day, the accepted answer got 39 upvotes and a check mark. All you got is a downvote. It means that answer worked and yours did not.
    – user477799
    Apr 12, 2017 at 5:13
  • It's an important metric, however, I have found them to be either false or only containing part of the answer. Most of the time I must scroll down and see if someone addressed the errors in the original answer. What you are referring to is an Argumentum ad populum "... a fallacious argument that concludes that a proposition is true because many or most people believe it: 'If many believe so, it is so.'" en.wikipedia.org/wiki/Argumentum_ad_populum Apr 13, 2017 at 14:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.